Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

compiler fatal error in multisim

Highlighted

I am trying to make a blink led with PIC16F84 mcu. I've tried with 8052, 8051 too. Both gave this compiler fatal error.

 

My version of Multisim are 14.2 professional.

 

First of all, when i build my project, this prompt message pop up on the screen:

"The active project configuration project1 of MCU U1 is out of date.
Would you like to build it?"

I click in Yes

p0.png

Then, a compiler error show on the Results tab.

"Fatal Error: Unable to start the compiler"

p9.png

and the code didnt compile.

 

this is a freshy installation of multisim.

 

what should i do?

0 Kudos
Message 1 of 7
(114 Views)
Highlighted

help me please

0 Kudos
Message 2 of 7
(64 Views)
Highlighted

help, i did not find any talk about it in the search.

0 Kudos
Message 3 of 7
(43 Views)
Highlighted

help me dudes... sorry my english.. iam brazilian

0 Kudos
Message 4 of 7
(37 Views)
Highlighted

 

Hi gui__,

 

 

Except for some (minor) flaws your English is comprehensible, we can get the thought.

 

Other members of this forum may have not encountered this kind of problem or they might be busy with their own tasks so they can't provide the help that you need.

 

In my case I am only using Multisim Live (Free Subscription) so I don't have the necessary resource(s) to help you.

 

I think it's worth paying attention to your problem and the solution to this will help others too. I hope someone will be able to help solve your problem soon.

 

 

Best regards,

G. Goodwin

 

0 Kudos
Message 5 of 7
(31 Views)
Highlighted

Hi G. Goodwin,

 

I'm glad that you though my english comprehensive, it's a good signal.

 

I 'll be awating for some clues related to this question.

 

Some further details: I'm trying to use the compiler with the following configuration as in the image

 

 

Untitled.png

 

Thanks

Cheers

0 Kudos
Message 6 of 7
(18 Views)
Highlighted

Problem solved.

 

I had to go to C:\Program Files (x86)\National Instruments\Circuit Design Suite 14.2\hitech and execute the install of hitech compiler.

 

Apparently, Hitech compiler wasnt installed by default in my multisim.

0 Kudos
Message 7 of 7
(6 Views)