Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

Warning Activation license Multisim 14.2

Dear all,


I've recently installed Multisim 14.2 (Education edition).

My University provided me the Serial Number for activation of the sofware; however, when I input it a message comes up: WARNING ACTIVATION.

My colleagues didn't have thisproblem.


I've installed the software in a Boot Camp partition of a MacBook Air.

I've tried to connect to other network but still same issue.


Any of you has an idea of what could be the problem?


Please, find attached shots of the error and information of my operative system




Download All
0 Kudos
Message 1 of 6

Hi. I'm having the exact same problem at the moment, I have my university provided serial number for multisim education and every time I try to enter the code it just says activation warning. Did you manage to find a way around this?

0 Kudos
Message 2 of 6



I'm still struggling with it. If I found the solution I'll let you know.




0 Kudos
Message 3 of 6

Hello, I am having the same issue, did you ever figure out the problem? 

0 Kudos
Message 4 of 6

Hey, nothing really ended up working for me so I had to buy a windows laptop. I suggest you do the same, buy a budget one.

0 Kudos
Message 5 of 6

Hello Adrian,


Yes, I solved it. 

I installed Multisim in a virtual machine with Windows on my Mac, and activated the license in it with no problem. Then I came back to the Windows version on the Boot Camp, and I could use Multisim is perfectly.


To be hones I do not understand the root cause of this, but it did work.

Good luck!

0 Kudos
Message 6 of 6