Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

Ultiboard crashes with 3d, V14.1

Go to solution

I finally reached a point where I have some time to clean up my libraries and do a better representation of the 3d model of the components I created but now whenever I click on anything having to do with 3d, Ultiboard hangs briefly and then shuts down. I've tried the same thing on my windows 7 laptop and it doesn't have a problem so it is either a Windows 10 issue or something corrupted with this install. Any ideas on how to approach this? 

I'm running:

Ultiboard Power Pro Edition

Application Version: 14.1.0 (14.1.31), Database version: 14.1.a

Build date: Monday, January 23, 2017, 9:22:28 PM

Processor: Intel Core i7-6700K CPU @ 4.00 GHz

Installed RAM: 64.0 GB

System type: 64-bit operating system, x64-based Processor

Windows 10 Pro

Version 1803

OS Build 17134.285

If any of that helps. 



0 Kudos
Message 1 of 5

I tried running 'repair' on the Power Pro installation and that didn't help. 

0 Kudos
Message 2 of 5



Can you tell us which steps you follow in order to reproduce this behavior?  You mentioned you cleaned some libraries, have you deleted any components related to Multisim? 


Have you tried to reinstall the software in Windows 10?

Warm Regards, 



0 Kudos
Message 3 of 5

Ok, scenario #1: 

I open the library manager. Click on a part I created in the past. I select 'Edit/properties'. I click on the 3D tab, Ultiboard shuts down. 

Scenario #2: 

I open a design, I click on 'Tools/View 3D'. Ultiboard shuts down. 

Scenario #3: 

I run the part wizard. I go through all the steps for creating a part. For this example I just click on 'next' for every prompt until I get to the end and I click 'finish'. It creates an 8 pin dip part. I then click on 'edit/properties' and when I click on '3d data', Ultiboard shuts down. 


When I say 'shuts down' it just closes instantly. 


I said I had time to start cleaning up my libraries, this was my first task. So I've done nothing else. 

As I mentioned before I ran the 'repair' function which reinstalls much of the software. I haven't done a complete reinstall yet as that is a lot of work getting everything set back up again as it was before with all my settings, design rules, checks, etc. That's why I am asking for help here, so I can try some other thing before resorting to completely reinstalling the software. 

0 Kudos
Message 4 of 5
Accepted by topic author jg_geadinc
10-10-2018 05:31 PM

Looks like it was a problem with my NVidia graphics driver. I noticed the updater application wasn't running in my system tray so I started it manually which it then reported there was an updated graphics driver available as of Oct. 4. I installed the new driver and tada! It now works without crashing. 

0 Kudos
Message 5 of 5