Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Ultiboard 14.0 : Drill file is corrupted

Solved!
Go to solution
Highlighted

Hello,

 

There are errors in the drill file. See attachment. There something wrong with the floating point (NO floating points in the drill file)

 

Regards,

 

Lieven

 

 

0 Kudos
Message 1 of 13
(3,475 Views)

Hi, 

 

What do you mean by corrupted? How have it become corrupted, is it a drill file generated through ultiboard without modifications? What format are you using? Have you followed the tutorial on the link below? 

 

Exporting Gerber Files from NI Ultiboard

http://www.ni.com/tutorial/6952/en/

 

/Anton

0 Kudos
Message 2 of 13
(3,412 Views)

Hi Anton,

 

Gerber files are OK it's only the drill file is not OK.

 

The file looks like:

 

M48
METRIC,TZ
VER,1
FMAT,2
DETECT,ON
ATC,ON
T1C3.0000
%
T1
X50000Y350000
X150000
M30

 

and it must be:

 

M48
METRIC,TZ
VER,1
FMAT,2
DETECT,ON
ATC,ON
T1C3.0000
%
T1
X5.0000Y35.0000
X15.0000
M30

 

NC drill and gerber properties are set to METRIC. Coordinate format for geber and drill are set to 3/4

 

Regards,

 

Lieven

0 Kudos
Message 3 of 13
(3,404 Views)

Hi Lieven, 

 

I tried doing a quick test, and I get the same behaviour when trying to generate a drill file. Are you sure that the file is corrupt, i.e. are you sure that there should be decimal points in it? What format are you using, the standard format should be the excellon format and in this there should be no decimal points.

 

https://en.wikipedia.org/wiki/Excellon_format

 

I tried opening the file with the online gerber viewer and it seem to understand the coordinates, how do you view the drill file?

 

/Anton 

0 Kudos
Message 4 of 13
(3,358 Views)

Hi Anton,

 

Are you use my attachments Anton ? I guess that you make, or create a new file. So i download ultiboard 13 (Demo). and create the same drawing in ultiboard 13. After generating the gerber and drill files all

the problems with the drill file are disappeared. Thats not normal. So what can i say. Maby the file is not corrupted(14) but the generated data is wrong.

 

Kind regards,

 

Lieven

0 Kudos
Message 5 of 13
(3,342 Views)

Hi Lieven, 

 

I tested both with your attached file and by making a new one and I saw the same result, that is no decimal points in the drill file. So are you saying that you get the decimal points using ultiboard 13?

 

/Anton

0 Kudos
Message 6 of 13
(3,340 Views)

Hi Anton,

 

I generate the files now in Ultiboard 13 (Demo) yes. And yes there are decimal points in the drill file. See new attachment below.

 

Regards,

 

Lieven

 

 

0 Kudos
Message 7 of 13
(3,332 Views)

Hi Lieven, 

 

I have not been able to get a definite answer to wether the missing decimal points are the expected behaviour or not. Since they are in version 13 of Ultiboard I have submitted a corrective action report and I'll let you know what reply I get. 

 

/Anton

0 Kudos
Message 8 of 13
(3,301 Views)
Solution
Accepted by topic author Lieven_1
01-20-2016 01:43 AM

Thank you Anton. I'm still waiting for a solution.

 

Regards,

 

Lieven

0 Kudos
Message 9 of 13
(3,294 Views)

Do you have access to Ultiboard 13 and can you use this in the meanwhile? An other solution would be to either programmatically or manually parse the file and insert the decimal points. 

 

After the problem has been verified by R&D it will still take some time to fix, verify and releas of an eventual patch, so I would not wait for it. 

 

/Anton

0 Kudos
Message 10 of 13
(3,291 Views)