Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Trouble simulating LED matrix

Highlighted
Hi again,
 
Im once again having trouble running a simulation. I believe my ciruict is alright but i keep on getting errors. The circuit is supposed to scan each row of the LED array, each time a row is activated the data entered at the columns changes. So row1 = high column data=A, row2=high culumn data=B and so on.
 
I have attached the ms9 file if anyone can help.
 
thanks
 
Wayne
0 Kudos
Message 1 of 5
(4,257 Views)

I understand what you are trying to do, but I can't seem to find a way to select the column without the simulator popping up a timestep error (Multisim 2001). The only way I could do it was to individually ground each column through a 330 ohm resistor and rerun the simulation for each column.

This may work in the real world, but the simulator is having difficulty with it. Maybe someone else can provide better a better solution than me. I will continue examing it to see if I can find a way to do it, but as of now I am just as baffled as you are.

Kittmaster's Component Database
http://ni.kittmaster.com

Have a Nice Day
0 Kudos
Message 2 of 5
(4,252 Views)
EUREKA!!  I found it. My last post gave me the idea. Just add 330 ohm resistors in series with each line coming off the word generator. This worked for me so I hope it works for you.
Kittmaster's Component Database
http://ni.kittmaster.com

Have a Nice Day
Message 3 of 5
(4,250 Views)

That worked perfectly thanks. Is this a common fix for timing errors?

Thanks again

 

Wayne

0 Kudos
Message 4 of 5
(4,243 Views)
I am not sure if this is common fix for timestep errors. What I have found is that when Multisim starts popping up error messages then there is something it doesn't like about the way your circuit is constructed. It is then up to you to figure out what it is that it is complaining about. This can be a fustrating process as you have seen. Most of the time it is just trial and error process to get your circuit working the way you want without Multisim complaining about it.
Kittmaster's Component Database
http://ni.kittmaster.com

Have a Nice Day
0 Kudos
Message 5 of 5
(4,237 Views)