Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem: Accessing the database.

Solved!
Go to solution
Highlighted

Hello.

I have a problem with my NI Multisim 12 (Student Edition). It installs correctly, and register correct too, but when I start the program it shows these messages

"Problem: Accessing the database.

The Master Database cannot be accessed. Features using the Master Database will not be available."

 

And the same for Corporate Database and User Database.

 

At the end, it shows this message:

"Multisim has detected that the Master database is not registered to the current user. Reinstall the program from the original media."


I have the original media from Labview 2012  and for Multisim 11 (from a myDaq).
After that, I can place any component because the program can't access the databases. I can open previous designs, but it doesn't simulate correclty.

I am the only user in the computer, and I am the Administrator.
I have a 64 bits Win7 with Core 2Duo 3Ghz. 
I have recently installed Labview 2012, wich includes this software, so I uninstalled previous Multisim.

I have used Mutisim 11 in the same computer with no problem. I have tried to reinstall Mutisim 11, Mutisim 12, erasing windows register, deleting the files after installing, giving permision for all the files and nothing works. Every time I install again Multisim it shows these messages.


Please, help me!
Any help, or anybody with this problem or similar, let me know too.

Thanks!!! 🙂

0 Kudos
Message 1 of 7
(5,283 Views)
Highlighted

Hello, AndresCF

 

By any chance you have uninstalled a 3rd party software called Ultra Librarian recently, don't you? Sometime when you uninstall that software or another 3rd party software, you have some Microsoft registries that Multisim needs uninstalled. Take a look at this forum discussion.

 

http://forums.ni.com/t5/Circuit-Design-Suite-Multisim/Multisim-Database-Error/td-p/930470/highlight/...

 

Let me know if it helps.

 

 

Regards,

Diogo Aparecido
Engenheiro de Aplicação
National Instruments Brasil
0 Kudos
Message 2 of 7
(5,240 Views)
Highlighted

Hello, AndresCF

 

Sorry, I posted with the wrong account.

By any chance you have uninstalled a 3rd party software called Ultra Librarian recently, don't you? Sometime when you uninstall that software or another 3rd party software, you have some Microsoft registries that Multisim needs uninstalled. Take a look at this forum discussion.

http://forums.ni.com/t5/Circuit-Design-Suite-Multisim/Multisim-Database-Error/td-p/930470/highlight/...

Let me know if it helps.


Regards,

Plínio Costa
Senior Techinical Support Engineer
National Instruments Brazil



0 Kudos
Message 3 of 7
(5,234 Views)
Highlighted

Yes, I have installed and unistalled UltraLibrarian recently. I don't gave it too much importance hehe. I will go to the link and I hope it works. 
LOTS OF THANKS!!!

0 Kudos
Message 4 of 7
(5,212 Views)
Highlighted
Solution
Accepted by topic author AndresCF

Again, Lots of thanks. I`ve solved the problem just right now. I have to modify the windows register following the instructions in the link. Thanks Smiley Very Happy
PD: Don`t use Ultralibrarian unless you have a non-free license! hehe.

0 Kudos
Message 5 of 7
(5,208 Views)
Highlighted

This link gives an UNEXPECTED ERROR.  I have a student with the same issues but with 14.2 education version.

 

0 Kudos
Message 6 of 7
(821 Views)
Highlighted

The simplest solution ( that is 85% accurate ) is to reinstall / repair using the original setup.

 

If that doesn't solve the problem, and you also receive a database not registered to user error, go to Options>Global Preferences (As on Multisim 12.0) and note the location of the Databases. Then make another empty folder anywhere on your system named 'NI Databases Backup' or anything clear and after that, copy all the database locations to a text file and the databases to the folder you created. Then paste the folder location along with the database name in all the database options. The master should be MSCOMP_S.PRD, the Corporate should be CPCOMP_S.PRJ, and the user should be UsrComp_S_XXXX.usr, with XXXX your username.I will also provide some links to download databases from NI 12.0 later.

 

Then go to the folder location that is indicated in the User Configuration Options as Configuration File. Close Multisim. Then delete all the files in the folder. Restart your computer. Open Multisim. The problem should be resolved.

0 Kudos
Message 7 of 7
(80 Views)