Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Oscilloscope runs very slowly

Highlighted

Hello,

 

I am a new user with multisim and running circuit simulations altogether. I am trying to look at a simple square wave pulse with the following settings (below). I would like to look at this pulse over the span of 45 seconds or so. I am finding that the o-scope is running reallyyy slowwww. I can see when I adjust the timebase scale that the simulation is running in the micro-seconds range. How do I make it run at a rate of seconds? I have already tried adjusting the max time step under the "interactive simulation" settings. Is there another setting I can look into? 

 

Please let me know if you'd like to look at any other settings I have setup for this simulation. I believe I am running V14.2 of Multisim

 

Thank you for your help in advance!

 

Kyndal6_2-1594660105094.png

 

 

Here are my o-scope settings:

 

Kyndal6_0-1594659755840.pngKyndal6_1-1594659805812.png

Kyndal6_3-1594660704731.png

 

 

0 Kudos
Message 1 of 2
(116 Views)
Highlighted

Hello, I don't know how the virtual oscilloscope in Multisim is implemented but I would consider two things:

 

1. The 1ps rise and fall times are very small compared to your period and are not realistic. I would set those to some more sensible value. For a 10s period, rise and fall times in the us or even ms range are plenty to obtain a square wave.

 

2. In a real oscilloscope the sample buffer length is finite and above a certain time base setting the oscilloscope will switch to continuous acquisition. It means that you will see a scanning/running waveform instead of a steady curve. This is also related to the sample rate. Again, it depends how much the virtual instruments mimics the real one.

0 Kudos
Message 2 of 2
(65 Views)