Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

No footprint preview


No footprint preview



I've got an rather anoying problem. and I don't know what I did to cause this(otherwise I would've fixed it already).

As you can see in the title, I can't see any footprint previews in ultiboard.


This is not irritating when searching for the right part, but also when I'm working in the part wizard.


I've repaired Ultiboard and Multisim twice but that didn't do the trick. I've also to reinstalled it neither did that work.

After comparing the Global options and PCB properties with another(working, on another device) version of Ultiboard. I coulnd't find a single difference between the 2 settings.

Part wizard.PNGPart WizardPlace.PNGPlace Part





0 Kudos
Message 1 of 6

Re: No footprint preview

"This is not only irritating..." -Line 6.

"I've also to reinstalled it, ..." -Line 8.


I see I can't edit the post..

0 Kudos
Message 2 of 6

Re: No footprint preview

Hi Derek!


That's an interesting issue you face, I have never seen something similar (yet). I have some ideas on how to fix this:

  1. What version of Ultiboard are you using?
  2. You said you already repaired Ultiboard. Does this refer to the Windows installer? I am asking because this process does (describing it simplified) only check if files are there, but does not overwrite existing files (that might be corrupt). NI Installers have an option called "Force Reinstall" that actually does this (Force Reinstall Non-Working or Corrupt NI Software). Have you already tried this? 
  3. Are the screenshots in your posting from a new, fresh project? Or did you already define any layers?
  4. Can you please check your database paths? It's in Options » Global Options » Path.
    You stated the Global Options on the "broken" machine are the same as on a working machine. Can you please check
    1. if all three files (prd, prj, usr) are actually there (obviously at least some of them are, as you get a parts tree).
    2. if they are in a folder named "14.1" (or whatever version you are using), or if it's a database migrated from an older version.
  5. What happens when you copy the database from the working installation to the broken one? Does it solve the issue?
  6. What Operating System are you using? Which version? What graphics driver are you using?

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 3 of 6

Re: No footprint preview

whoops, sorry for the late response it's been quiet busy lately.


1. on the broken machine is 14.1 and the working machine 14.0

2. I'll try the cmd repair later today

3. the screenshots are from an old project, but when I open a new project the project remains.

4. the paths and files are correct.

the database is exported from 14.0 to 14.1. but the footprints weren't visible in 14.0 either.

5. I'll try that too later today.

6. windows 10. the display drivers does not seem to have any effect, currently at (amd) 18.12.2 but changing it to older versions did not fix it either.

0 Kudos
Message 4 of 6

Re: No footprint preview

Hey Derek, 

Thank you for posting the detail. Have you tried #2 and #5 since then, and did they work our for you?

Ingo – LabVIEW 2013, 2014, 2015, 2016, 2017, 2018, NXG 2.0, 2.1, 3.0
0 Kudos
Message 5 of 6

Re: No footprint preview

Hey Kaiser,


I was booting up Ultiboard to swap databases, only to find out my Ultiboard and Multisim license have expired on the 31th of december.

I'll first have to wait and get a new license from school.


When I've got a new license I'll try the swap and reset and post the results.



0 Kudos
Message 6 of 6