Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Multisim Live - High Frequency Amplifier Behaviour

Hello,

 

  I've simulated a number of fundamental types of transistor amplifier in Multisim Live as demonstration circuits for students.  Due to COID-19 etc, carrying out experiments practically isn't currently possible.

 

  When plotting a frequency response (gain vs frequency) of these amplifiers practically, it is possible to see the frequency drop-off at both low and high frequencies.  In Multisim Live, the same circuits exhibit unrealistic high-frequency behaviour; i.e. the gain doesn't drop off at all, even at ridiculously high frequencies >1THz.

 

  I've always thought this is because the high frequency behaviour isn't part of the SPICE models used, but is this the case?  I'm making use of SPICE models for the transistors in each circuit, but not for any of the other components.  Is it possible to set resistors/capacitors/wires even to "real-life" behaviour?

 

  Thanks for any suggestions.

 

 

wt_higo_0-1610969806872.pngwt_higo_1-1610969836199.png

 

0 Kudos
Message 1 of 7
(159 Views)

Hello,

 

That's actually interesting issue.
Could you please send a screenshot of your scheme and write the parameters that you have set up.

Want to try it on my side and try to understand what is causing this behaviour/issue.

0 Kudos
Message 2 of 7
(117 Views)

Hello,

 

  any class-a type transistor amplifier will exhibit this behaviour in my experience, but the response shown was from a JFET buffer amplifier.

 

  Hopefully this link will work:

 

https://www.multisim.com/content/wzrtLcPAPStuiZUWemymWH/common-drain-amplifier/

 

  The SPICE model used for the JFET is a BF256B.

 

Best regards 🙂

0 Kudos
Message 3 of 7
(114 Views)

You can use the Non_Ideal_RLC components to include parasitics. 

0 Kudos
Message 4 of 7
(102 Views)

Hi,

 

  is this an option in the paid-for version of Multisim Live?

 

  When I try to change the component model (which is where I presume this setting would be), I only have one option:

wt_higo_0-1611650512344.png

 

Thanks for your help.

0 Kudos
Message 5 of 7
(96 Views)

They are not yet included there. But that would be the place. 

 

They are only available in desktop. For Live you would have to build the equivalent circuit model.

 

See https://electronics.stackexchange.com/questions/472217/equivalent-circuit-of-a-non-ideal-resistor

0 Kudos
Message 6 of 7
(88 Views)

Thanks very much for the info 🙂

0 Kudos
Message 7 of 7
(81 Views)