From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing reference designators

I have created several parts in Multisim/Ultiboard.

 

In Multisim the reference designators appear correctly.

 

In Ultiboard none of the parts has a reference designator.

 

I have repeated the component creation steps over and over in both Multisim and Ultiboard. There is no procedure for adding a reference designator to the footprint that I can fine. I have searched through the User Manuals and the Help files for both programs and there is no mention of adding reference designators to footprints.

 

I am just about fed up with this &*(978% software. Can anyone explain how to get reference designators to appear in footprints?

 

****

 

An associated problem - every now and then when I place components (apparently any type) the reference designator is always Uxx. Place a capacitor, and it is Uxx, resistores are Uxx, etc. Everything seems to default to "U".

 

I can edit this one component at a time, but it is a pain in the &*^!

 

Any idea what is causing this mess?

 

Phil

 

0 Kudos
Message 1 of 6
(4,178 Views)

I solved the first problem. When new parts are added by forward annotation from Multisim the reference designators are hidden. If this isn't stupid, nothing is!

 

In Ultiboard if I pull up the "Properties" dialog and look in the "Attributes" tab I can change the "Visibility" column from "None" to "Value" and the reference designator is displayed.

 

Now I have to do this for every new part!

 

Phil

0 Kudos
Message 2 of 6
(4,177 Views)

Hi Phil,

 

For your second question. What version of Circuit Design Suit are you using? In Multisim version 11 and 12 if you place a resistor, the RefDes should be Rxx, and if you place a capacitor it should be Cxx. The Ultiboard RefDes should be the same as the one in Multisim. If you still come across the same problem, would you please upload your design files if convenient?

 

Cheers,

 

 

Derek Z.
National Instruments
0 Kudos
Message 3 of 6
(4,158 Views)

DrPR,

 

Reference Designators are organized to the related Family for a specific component.    If you create a group of custom zener diodes for instance, in the USER or CORPORATE database you can create a family called 'ZENER" under the Diodes group.  You are correct in that the default refdes is "U", which the software does not autodetect in any way.

 

To change the 'U' to a 'D' reference designator go to:

 

Tools->Database->Database Manager

 

Go to the 'Family' tab... and go through the appropriate families you've created (CORP or USER database).   On the right there will be a box labeled 'Component RefDes' - you can specify any alphanumeric refdes (up to 5 characters, no spaces).

 

When you place a new component it will update with the new refdes (note it will not go and update old refdes already placed).

 

 

0 Kudos
Message 4 of 6
(4,140 Views)

Thanks.

 

I have figured this out, but there seems to be more to it than that.

 

When I first had a non-IC part placed with a "U" refdes it happened when I replaced an existing part - something like Cxx became Uyy - nn and yy were different also.

 

Then I placed a newly created part, from a newly created User library family, and it came out Uzz. I deleted it, edited the new family refdes to be something other than U, and tried again. It was still placed as Uzz.

 

I think it is necessary to shut down the program after creating a new library family, then restart the program before the refdes change will stick - but I am not certain of that.

 

Phil

 

0 Kudos
Message 5 of 6
(4,138 Views)

If you change the invisibility in the Footprint Editor and then re-transfer all to PCB, all the references will appear. Note that re-transfer is not the same as forward.

0 Kudos
Message 6 of 6
(319 Views)