Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Initial testing Multisim + ULTIboard Buglist

I have been testing Multisim and ULTIboard (V10.0.144) for 1 day to see whether it really works and is usable.

I'm still working with Ulticap and Ultiboard V5.7x and consider changing over.

I have found the following problems in the process of Schematic-entry to layout.

 

Multisim

1.  Netnames can not have delimiters like + and -.That is not so nice, specially, since imported schematics allow this and  are not checked for this.

2. Once a schematic is transferred to ULTIboard, the router only routes on the top layer. This is caused by an incorrect setting in Multisim (routing layer is set to top by default.
This propagates via the netlist to ULTIboard. Manual routing is not limited.

3. Multisim allows enabling of gate and pin swap. The default is OFF. This should probably be ON.

4. gate swap know On/Off, but ultiboard interprets On as "Internal swaps only". The designed obviously did not know the idea behind this. Ultiboard allows inter-gate swaps if the other (common connections) match with the other package. Thus Ultiboard should interpret ON as "Advanced swapping".

5. After gateswap (in ULTIboard) and backannotation into Multisim, the unused gate list does not represent the new situation. When placing new gates, one can place a gate that is already in use.
6. The Reports "Bill of material, "Netlist report" and "Spare gate report" lack a CSV (comma or tab separated) list. If excell is not available, but OpenOffice or a database is, there is no way to get there. Oddly enough, the spreadsheet view does allow CSV output....., but does not have a BOM.

 

ULTIboard

1. Slotted holes can be made and show correctly. However in the DRILL file, it is wrong. In my case, a horizontal slot came out vertically. A vertical slot also vertically.

2. A forward annotate to ULTIboard un-places parts that are updated. This is NEVER what you want. Specially if you want to change all resistors and capacitors to a different SMT shape.

3. Gate swapping in Ultiboard does NOT allow to swap to unused gates. This makes the function sort of useless. It must allow to swap to ALL (identical) gates in a package.

4. The pin swap function does not show which pins can be swapped. You now have to rely in Click-and-miss.

3. There should be an option per component, to exclude it from component  shoving. Think of a heat sink or RF shielding can, that must be placed over other parts.

 

 Note that I have not done any serious tests on the gerber and drill output.

 

I know that this is a 'negative' list, but these are not difficult issue to solve and do make the package workable.

Also, I do like a number of important features that do work:

- Multiple instances of a single (hierarchical) sheet

- Automatic sheet symbol creation/update

- Copper in footprints

- drawing on any layer, allowing for proper production preparation.

 

0 Kudos
Message 1 of 8
(3,360 Views)

Most of those issues are known, hopefully they will be resolved.



Signature: Looking for a footprint, component, model? Might be here > http://ni.kittmaster.com
0 Kudos
Message 2 of 8
(3,317 Views)

Hi, first of all, I really want to thank you for taking the time to share your feedback. I went through all the suggestions and I will provide you with the

"where we are at" on each of them.

 

Before listing each feedback, I wanted to recommend that you use the latest evaluation edition (10.1); which you are also able to update to the latest build(10.1.0.1) if needed. This will ensure that you are working with the most up-to-date evaluation. 

 

I will describe each suggestion with the same number that you had on your posting.

 

Multisim

  1. For the next update (date TBA) we are allowing delimiters in more parts of the suite (Multisim and Ultiboard) which were previously forbiden. However, specifically for netnames we have not yet implemented the ability to use delimiters. We are currently working to overcome this limitation in the mid-term.
  2. This has been fixed in two phases, one was added to the 10.1 release, and the other phase will be added in our next update (date TBA).
  3. I filed a feature request for R&D so they can change the default settings. Makes a lot of sense to have it enable by default.
  4. I filed a feature request for R&D so they can evaluate changing the current behaviour.
  5. This was hard to reproduce but I was able to see the behaviour once. I filed a defect for R&D. I'm using the latest version (10.1 with update 10.1.0.1). Part of the fix for this is in the works, is in a mid-term improvement project for Forward and Back Annotation procedures.
  6. I filed a feature request for R&D so they can add this ability to the reports.

 

Ultiboard

  1. This is fixed. Is working correctly in the latest version.
  2. The fix for this is in the works, is in a mid-term improvement project for Forward and Back Annotation procedures.
  3. I filed a defect for this manner. Unused gates should be available to be swapped from Ultiboard, agreed.
  4. I filed a feature request for this one. The pins that belong to the same PINGROUP for swapping should show a guide like the Gate Swap.
  5. I filed a feature request for R&D so they can review this request.

 

Thank you for passing this information to us, I'm glad to see that a couple of the issues are already fixed in the current versions, other fixes are already in the works, and new features proposed will be recommended for future releases. This feedback helps us improve our product on every release.

Nestor
0 Kudos
Message 3 of 8
(3,295 Views)

Hi there,

 

There is a way to exclude components from part shoving. You can enable this for individual components by doing the following:

  1. Select the component that you want to exclude from part shoving
  2. Click on Edit>>Properties
  3. Click on the Position tab
  4. Click on the Locked check box to enable it
  5. Click OK

You should now be able to other components around without changing its position.

----------
Yi
Software Developer
National Instruments - Electronics Workbench Group
0 Kudos
Message 4 of 8
(3,278 Views)
Highlighted

Hello Nestor,

 

Thanks for taking this seriously. Overall I like the result of the package, so if the support is good and R&D is active, it will be great.

I think both packages (multisim and ultiboard) are good by themselves, but the connection between the two needs some work.

For instance, assigning a footprint to a symbol. Why not call the ultiboard's dialog for selecting an footprint from the database?

Now one has to copy a name manually (as if the 2 packages do not belong to eachother).

Showing dimensions on footprints, in a larger window would be really helpfull. Remember, layout is a 2D cad issue. It must be exact, or a part will not fit the footprint.

Also, I found that the properties of an inductor do not allow assignment/changing of a footprint.  Other 'basis' symbol do.

 

Best regards,

Alex

 

0 Kudos
Message 5 of 8
(3,218 Views)

Thanks Alex for pointing that out. We are working on integrating the two packages more and more each release. As far as the assignment of a footprint to an inductor... I think you are still running v10.0 evaluation, please run v10.1 see my previous post for links. In v10.1 we changed those dialogs so that you can now assign footprints to RLC components on their value tabs, rather than from the spreadsheet view.

 

Thanks!

Nestor
0 Kudos
Message 6 of 8
(3,215 Views)

Hello Nestor,

I'm afraid that I'm now completely stuck.

After a change in Multisim, the new netlist crashes Ultiboard, even without a 'general protection error'.

That means, _exit() is called directly....

 

You can try this by importing the netlist into the design.

 

PS the file venteo.txt is the netlist, I had to rename it since this message board does not accept a ewnet file.

 

 

best regards,

Alex

0 Kudos
Message 7 of 8
(3,164 Views)

Hi Alex, are you sure you are running version 10.1? I just tried it in 10.1 and it works OK. It does gives some DRC errors about a package not found though but no system failure.

 

Let me know if you are running 10.1. Thanks!

Nestor
0 Kudos
Message 8 of 8
(3,087 Views)