Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Importing SPICE model for BFP720F BJT transistor in Multisim

Solved!
Go to solution

Hi,

 

I'm trying to get the SPICE model for the BFP720F transistor provided by Infineon to work in Multisim.

I've attached the model as provided by the manufacturer.

If I import it as-is, I get error messages about "invalid node identifier '<4>'" (I've translated that from German, so it might not be exactly this message in the english version).

So I tried replacing all the '<4>' with '4', which seems to help, but now the error is "Temperature adjusted parameter 'VJC(PC)' is negative" and "Incorrect use of model parameters"... Now I really don't know what to make of this.

 

Is the provided model in a wrong format? Can I somehow get it into the right one so I'm able to use it?

 

As I need this for my semester project at university, any help would be highly appreciated.

 

Thanks in advance!

0 Kudos
Message 1 of 3
(2,192 Views)

Hi EE-Student, 

 

can you give me a Step by Step of how you get the error? Are you using the component wizzard?

 

Here is a small tutorial:

 

Importing a SPICE Netlist for Simulation in NI Multisim - National Instruments
http://www.ni.com/tutorial/11743/en/

 

A different solution might be to modify a similar component that is already available in the database:

 

How Can I Import a SPICE Model Into Multisim? - National Instruments
http://digital.ni.com/public.nsf/allkb/2373E75D8B375EA1862575D2004D9C88

 

I hope this helps you along, otherwise just post the steps, so I can reproduce the issue.

Cheers,

Niko

 

 

Niko NR
Systems Engineer, National Instruments
0 Kudos
Message 2 of 3
(2,174 Views)
Solution
Accepted by topic author EE-Student
05-25-2016 08:33 AM

Hi NikoNR,

 

While writing a detailed description of what I did exactly using the component wizard, creating the component again in Multisim from scratch, I found that there are different SPICE models provided in the package meant to be used with AWR MWO. They have a different file extention, but are normal SPICE text files inside.

It turns out that these actually work with Multisim! The difference is small, there's only a temperature parameter (TNOM) which is absent in these models, as opposed to the "general" one I first tried to use. It seems that Multisim had a problem with this parameter, leading to the error I've encountered.

 

So anyway, the problem is resolved now. Thanks for your assistance Smiley Happy

 

Have a nice day,

(The now a lot happier) EE-Student

 

----

Edit: I've attached the SPICE model I ended up using, in case anyone ever encounters a similar problem. The only modification I've made to this, is to replace the '<4>' with '4' in the diode part (only one occurrence here). I had to zip it to be able to upload it with it's original extention (.mdl).

0 Kudos
Message 3 of 3
(2,161 Views)