Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Import PCB Designs into Ultiboard and link to original Multisim design.

I am trying to work with a third party, who is doing the PCB layout.  I have a board design in Multisim which I export the netlist to them for Protel.  How can I bring the completed design back into Ultiboard?  dxf files do not seem to contain all of the component information.  I have tried dxf and .pcb files from them and none seem to come close.  Thanks.

0 Kudos
Message 1 of 6
(3,956 Views)

Hi Martin,

 

In Ultiboard, select File>>Open and where you see All support files click the down arrow, there is an option to open Protel file. I should warn you, the last time I looked at this, there were many hidden issues such some via not properly connecting to a trace and this only happen with a few via, and there were other issues that don't recall right now. If your design is complex, importing a Protel file is very dangerous.

 

DXF was intended for importing board outline and logo.  Data inside a DXF contains only shapes, it doesn't have netlist, pad information, clearance etc... So importing a complete design is not useful.

 

My recommendation is to redo the design.

 

Tien P.

National Instruments
0 Kudos
Message 2 of 6
(3,947 Views)

I found the way to open a .pcb file, but it displayed garbage.  It only displayed a bunch of x? on the Top Overlay layer.  It looks like it still has the parts and netlist.  This is a simple design which only has placement at this point.  The board outline and part shapes don't display.  Any info would help.

0 Kudos
Message 3 of 6
(3,945 Views)

It looks you imported a netlist.  The X? footprints indicate that Ultiboard was not able to locate the footprints specified in the netlist in the Ultiboard library.  If the board was already layout, you should see the footprint traces

Tien P.

National Instruments
0 Kudos
Message 4 of 6
(3,942 Views)

The 3rd party I am working with has exported the file in 3 different versions from Protel, 3.0, 4.0, and 5.0.  5.0 is a .pcbdoc file which is not listed as supported.  The board is now routed but I still get garbage when I open the file.  This doesn't even come close.  Any suggestions would be helpful.

0 Kudos
Message 5 of 6
(3,925 Views)

I'm having the same issue.

I'm trying to open the file the traces shows but no footprint.

And this is?

0 Kudos
Message 6 of 6
(94 Views)