Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

I upgraded my iPad to iOS 9 and now MultiSim Touch doesn't work. Any fixes available?

With iOS 9 when I try to start MultiSim Touch the screen quickly goes black and then returns to showing the icon.  Any updates on the MultiSim side that may fix this problem?

0 Kudos
Message 1 of 8

Discovered the same issue tonight.  Tried a power down, didn't work.  Checked on an update, none available.  Hopefully this is fixed soon, I need to simulate circuits for class tomorrow!

0 Kudos
Message 2 of 8

Hi  JamesKirk and DrCross


We are sorry for the inconveniences! We are working on an update that should be released soon that would fix this compatibility issue. The update should be available in about 3 weeks or less. 


Again, sorry for the inconveniences, we hope this does not affect your work too badly.



0 Kudos
Message 3 of 8

Just installed multisim touch on ipad Ios7.1.1, same issue touch any where in the app screen close not working. Please help

0 Kudos
Message 4 of 8

Hello I am currently working on getting updated information about this issue. As soon as I got a response I will post it.




Warm Regards,


Randy Cespedes

Applications Engineering

National Instruments 

Randy @Rscd27@
0 Kudos
Message 5 of 8

Hello pakplc,


The current version of Multisim Mobile 1.1.3


Requires IOS 9.0 or later. I believe this version solved the compatibility issues present in the previous versions.

Randy @Rscd27@
0 Kudos
Message 6 of 8

I posted this on the other thread where this issue is being discussed, here's the update:


Multisim Touch Crash Update


We have some updates for everyone who has had experienced the crash in Multisim Touch, I will split the news on whether you are running or can run iOS 9, and for those who want to maintain the older versions of iOS (e.g. 8.x or 7.x).


If you have iOS 9 or will update to iOS 9

For these users, the app should not be crashing at all, the app works fine in iOS 9 to the best of our knowledge. On any case, you will see a 1.1.3 version update in the App Store, feel free to apply that update. If you have an older version of iOS (e.g. 8.x) and the app is crashing, once you update your iOS the app will work fine, in case it doesn't just uninstall and reinstall.


If you have iOS 8.x or lower and will not update to iOS 9

If you are not interested in using the latest iOS version, and wish to keep your older version of iOS, we will ask you to uninstall the app from your iPad, then go back to your App Store account and download the app again, you will receive a message saying that your iOS is not compatible with the latest version of the app, however it will allow you to install the working version of the app that is marked with a different build (1.1.0). Once you do this, the app should work fine.


What am I missing by using 1.1.0 vs. 1.1.3?

In reality you are not missing any functionality, our 1.1.1 update was a code migration to support iOS 9 and 64-bit requirements set by Apple, and the resulting bug fixes from that migration. 1.1.2 was also a batch of bug fixes for the same code migration.


If the above procedure does not works and you still experience the crash, please update us in this forum post or open a new one (preferable).



0 Kudos
Message 7 of 8

iPad 3, iOS 12. MultiSim Touch has crashed. I don't know if it caused by software or operating system?  Are there other iPad models running 12 having such issue?

0 Kudos
Message 8 of 8