Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

How do I resolve bus-related system hanging?

My system has hung many times while trying to delete nets.  Sometimes it even hung while trying to delete traces or components.
I was able to recreate this problem using the 4014BT_5V.  I linked the "P" and "O" signals to seperate but merged buses.  I copied this circuit 15 times, and merged the buses into one.  I found that once I tried to delete a net, the system would just hang.  I did not have this problem when I had the 16 components linked to one bus tree using what appears to be an undocumented bus linking scheme.
Is there a problem with the way the system manages nets, or is this a random bug that creeps around?  Is this a bus problem, or a net problem?  If this cannot be resolved, I will be forced to look at another software packge.
0 Kudos
Message 1 of 4
Can you attach that circuit file so we can try to replicate the problem?... I tried on my system but did not got any misbehaviour. Just place the file inside a ZIP file and attach it.
0 Kudos
Message 2 of 4
There are two files.
test.ms10 <- will hang when deleting a net inside the bus.
test2.ms10 <- functions normally with the same operation.
0 Kudos
Message 3 of 4
Thanks for the circuit, that helped me understand what I was missing... so yes, you are right, is isolated to virtually connected buses... 'in multiple instances'... I made a different file to replicate it... I'm going to send this to the developers...
I was able to replicate it by making one instance with three virtual-connected buses that were merged... then make several copies of all this group and renaming the buses back to BUS1 for example, merging them...
Message 4 of 4