Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

Help : time step too small

Highlighted
I have a simple bridge rectifier circuit, however, when I tried to get the output using an oscilloscope, it gives me a message that time step too small.
 
Any help will be appreciated.
 
I have attached the circuit. Very simple circuit.
 
Thank you
0 Kudos
Message 1 of 6
(2,908 Views)
Highlighted

Hi okogidi,

Try doing the following changes in the Simulate menu:

Simulate>>Interactive Simulation Settings, change the Maximum time step (TMAX) to: 1e-003.

 Then go to the Analysis Options tab, SPICE Options>>Use Customs Settings>>Customize; in the Global tab change the Relative error tolerance (RELTOL) to 0.01.  Ok, Ok... and now run the simulation.

Let me know how it works,

Fernando, NI

Message Edited by Fernando DZ on 10-04-2007 12:01 PM

Fernando D.
National Instruments

0 Kudos
Message 2 of 6
(2,891 Views)
Highlighted

Solution found: Place a ground on the bridge rectifier where it attaches to your 1K resistor on Pin 4. This should cure the problem.

I hope this solves your situation.

Have A Nice Day

Message Edited by lacy on 10-04-2007 01:04 PM

Kittmaster's Component Database
http://ni.kittmaster.com

Have a Nice Day
0 Kudos
Message 3 of 6
(2,889 Views)
Highlighted

Hi Fernando. Just so you'll know the only thing needed here is a ground on the bridge and it will simulate with his current settings.

Have A Nice Day

Kittmaster's Component Database
http://ni.kittmaster.com

Have a Nice Day
0 Kudos
Message 4 of 6
(2,881 Views)
Highlighted
Hi lacy,  I tried using the Convergence Assistant, but yes, the circuit was needing that ground.
 
Thanks!
Fernando
Fernando D.
National Instruments

0 Kudos
Message 5 of 6
(2,874 Views)
Highlighted
Thank you everyone. It worked perfectly.
0 Kudos
Message 6 of 6
(2,866 Views)