Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

Error: lengths dont match 2, 4017, FFT Current Analysis

I have a problem here, when i want to measure a THD current with Fourier analysis the graph didn't show. that said  "Error: lengths dont match 2, 4017".

i have try a solution from ""  but that's didn't work.

Please help me . . .


this is a schematic what i want to analysis.

0 Kudos
Message 1 of 6

This was caused by a legacy issue with our internal simulation engine with the syntax used in some device parameters - in this case the square brackets used in the current expression in your output variable. 


This was fixed and works correctly in Multisim 13 and later versions. Which version are you using?

0 Kudos
Message 2 of 6

i'm using multisim 14.0

0 Kudos
Message 3 of 6

I am experiencing the same issue "Error: lengths don't match: 2, 3342". I am using multisim 14 as well.

Thank you

0 Kudos
Message 4 of 6

Don't know if it will work always, but this worked once for me. Knowing this is a bug of Multisim (I'm using 14 version), and noticing this occurs mostly with Voltage probes and not with current probes, I converted the voltage to current using a "Voltage-controlled-current-source" with a 1:1 output (1 Mho Transconductance) and a resistor in the output of the controlled source and set the Fourier analysis to output the analysis of the current of the resistor. Finally worked! 









0 Kudos
Message 5 of 6

Currently, This worked for me!!! I'm very grateful with you.

Working on a similar project, I hadn't been able to plot the Fourier Analysis for a 3-phase voltage, and the "Voltage-controlled-current-source" is an incredible solution!

Thank you very much.

0 Kudos
Message 6 of 6