Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

Error: lengths don't match: 1, 20001



I am a self learner and never really performed anything before in multisim, till this point I managed to do successfuly what I wanted to do. I am trying to use this software to make analysis of a circuit simulating a potentiostat. I have made a voltage adder, a potentiostat and a current follower - 3 OP amps.


I connect a diode to the potentiostat part and try to measure current flowing through the diode by measuring voltage at the output of current follower. Perturbation signal is a sine wave. When I try to simulate the fourier analysis of the current flowing through a resistor in a current follower. I keep getting error:


Error: lengths don't match: 1, 20001 


or a similar error - Error: lengths don't match: 1, 10001. I have not managed to locate this error in any search or help tools. I have tried to follow the guide NI gives for fourier.


Funny thing is that for fourier simulation of voltage I do not get the error. Have you encountered this error? For interest sake I would love to find out what that error means and what I am doing wrong.


Regards, Michal

0 Kudos
Message 1 of 4

Dear Michal,

in order to help us to investigate the described unexpected behaviour, could you please attach your simulation file? I could take a look at it and if I can reproduce the issue, I think I could come up with some suggestions.

Thanks in advance!


0 Kudos
Message 2 of 4

Dear Michal,

in the meanwhile I was able to reproduce the unexpected behaviour using a simple circuit.

To view the Fourier analysis output of a current type signal it is necessarry to use a probe on the wire of interest and set the output of the analysis accordingly. Please see the attached example.

Best Regards,

Message 3 of 4

Please read my answer in the following thread:


But I will repeat here for safety reasons:


Don't know if it will work always, but this worked once for me. Knowing this is a bug of Multisim (I'm using 14 version), and noticing this occurs mostly with Voltage probes and not with current probes, I converted the voltage to current using a "Voltage-controlled-current-source" with a 1:1 output (1 Mho Transconductance) and a resistor in the output of the controlled source and set the Fourier analysis to output the analysis of the current of the resistor. Finally worked! 






0 Kudos
Message 4 of 4