Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

usb 8451 install drivers not working

Solved!
Go to solution

I'm trying to install the usb-8451 SPI DAQ on Windows 10 Box.  I've downloaded the NI serial drivers and the individual driver for the device, but after installing the device isn't entirely recognized.  Windows knows its there and even knows its am 8451, but it doesn't have a device driver for it.  The device shows up in NI MAX, but it doesn't recognize a driver for the device.  Any ideas?

0 Kudos
Message 1 of 5
(211 Views)

More information.  Windows is complaining that the third party INF does not contain digital signature information.

0 Kudos
Message 2 of 5
(210 Views)

See attached for error when trying to force the use of the oem64.inf file.

0 Kudos
Message 3 of 5
(198 Views)

@Jim12345678 wrote:

I'm trying to install the usb-8451 SPI DAQ on Windows 10 Box.  I've downloaded the NI serial drivers and the individual driver for the device, but after installing the device isn't entirely recognized.  Windows knows its there and even knows its am 8451, but it doesn't have a device driver for it.  The device shows up in NI MAX, but it doesn't recognize a driver for the device.  Any ideas?


1. The USB-8451 is not a DAQ (Data AQuisition).  It is an I2C and SPI controller.

2. NI Serial is the driver for NI's serial boards (RS-232, RS-422, and RS-485).

3. The driver you need is NI-845x.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 4 of 5
(196 Views)
Solution
Accepted by topic author Jim12345678

I DID install the NI-845x drivers; that's the problem.  The driver install isn't working.  I tracked down the .inf file used to install the driver (oem64.inf) but when I tried to install the driver via Windows device manager I got the error that the driver didn't have a digital signature.  I tried to attach the oem64.inf file but the forum doesn't support posting .inf files.  I had to boot the computer in troubleshooting mode, disable digital signature verification and then assign the driver to the device.  After that, it works.

0 Kudos
Message 5 of 5
(164 Views)