Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

reduce timing for 8x8 matrix display

Hi all,
 
i am working on a 8x8 led matrix display. i'm using scanning method and thus requires alot of stacked sequence loops.
 
when trying to make different patterns, i am still unable to overcome the flickering no matter how well i simplify the program.
 
 i realise that this is due to the default time delay of a stacked sequence.
 
may i know how to eliminate or reduce this time delay to get a firm pattern?
 
Pls help me solve this problem.
 
Vivek
0 Kudos
Message 1 of 8
(2,460 Views)
Did you post this a few weeks ago?  It seems like I remember someone posting about an 8x8 matrix.  It inspired me to see if I could create a moving message board, which I did.  Send me the code (if possible) and I'll take a look.  I don't know that I can judge enough from your description to know what to do to solve the problem.
0 Kudos
Message 2 of 8
(2,448 Views)

hi,

thanks for the reply. I'll attach the file. But my 8x8 led matrix is a seperate hardware. I am using voltage and transistor fieldpoint modules to control the hardware. The file attached is a program for a definite pattern '9'.

The problem with the program now is that the pattern flickers alot. I am working to get a firm pattern without flickering. I doubt my program is too slow.

 

Pls try to help.

vivek.

0 Kudos
Message 3 of 8
(2,426 Views)
Sorry, I thought you were using LabVIEW front panel LED's.  I'll gladly look at your code, but I don't know anything about using FieldPoint or real LEDs, so I may not be of much help.  I am sure others would be able to help, though.
0 Kudos
Message 4 of 8
(2,419 Views)
ok sure. thanks anw. Smiley Happy
0 Kudos
Message 5 of 8
(2,404 Views)
Hi Vivek,
What hardware are you using to drive your LED matrix?  It sounds like the flicker might not be due to your VI.  If you post your code I'll take a look at it to see if it might be responsible.
Eric A.
National Instruments
Distributed I/O Product Support Engineer
0 Kudos
Message 6 of 8
(2,385 Views)

hi,

yup i believe its my software which is causing the flickering problem and i would appreciate if u could help on modifying my software.

i am using Voltage module (cFP-DO-410) and transistor module (cFP-DO-403). and the LED matrix is a pcb board with 64 LEDS in a 8x8 arrangement.

the selection of channels to light up is in the properties of the fieldpoint in the blockdiagram. and i believe u need the modules inorder to check how the property setting actually looks like.

 

Message Edited by vivek88 on 10-09-2007 09:10 AM

0 Kudos
Message 7 of 8
(2,378 Views)
Hi
I think you might try introducing a wait into your loop. I know my suggestion sounds odd since you are seeing flicker but this way you know when your processor is taking a break to perform other tasks. I think it would be pretty hard to replicate the issue without your hardware. Let me know what effect, if any, that has on your application.
Eric A.
National Instruments
Distributed I/O Product Support Engineer
0 Kudos
Message 8 of 8
(2,356 Views)