Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

pci-7831r card read as pxi-7831r by MAX

    I have a pci-7831r that isn't working. is brand new and this is its first instalation. i'm unable to read or write a voltage to any of the pins i am however able to measure the fixed voltage values (ie 5 volt on pin 1). The  card is read as a pci-7831r  in ni-rio  but is read as a pxi-7831r  in MAX. both labview and NI-DAQ wont detect the presence of the device. i have reinstalled the software and the card a number of times aswell as changed the pci socket used on the mother board.
has anyone else had  this problem?
regards
brad

0 Kudos
Message 1 of 7
(1,784 Views)
Hello Brad,
 
I have a few questions for you about your setup.  Is the device recognized as a PCI device under the RIO Device Setup?  Is this where you are seeing the board under RIO?  Where are you looking at the device under MAX?  NI-DAQ will not detect the presence of the device.  It does not use the NI-DAQ driver to program it's input and output.  If you open a new project in LabVIEW, right click on the project at the top and create a new target.  Under the window, if you select existing devices, does it appear under this list?  If the device is recognized by NI-RIO, then you should be able to connect to it.
 
 
Brian Coalson

Software Engineer
National Instruments
0 Kudos
Message 2 of 7
(1,757 Views)
Brad,
What version of the NI RIO driver are you using?

Regards,

Bassett
0 Kudos
Message 3 of 7
(1,751 Views)
thanks for the reply guys, i actually figured out myself that one requires to have software of the same version. we bought everything as one package, Nation instraments made a mistake by sending us labview 8.5 and the fpga module version 8.2.1 this drama has been fixed and i'm looking forward to fpga module version 8.5 turning up in the mail.
thanks for your help
brad
0 Kudos
Message 4 of 7
(1,744 Views)
No problem Brad, thanks for letting us know you got everything figured out.
Brian Coalson

Software Engineer
National Instruments
0 Kudos
Message 5 of 7
(1,722 Views)

Hi all,

I have a similar problem. 

NI Max have seen my PCI-7831R. However, when I make a new project, LabVIEW can not detect target board.

I already installed NI RIO 19.0. FPGA module. LabVIEW 2019.

 

VTD

0 Kudos
Message 6 of 7
(40 Views)

You should start a new thread, but if you look on this page, you can see that PCI-7831R is not supported on LabVIEW 2019. You need LabVIEW 2016 or below and NI-RIO 16.0 or below.

0 Kudos
Message 7 of 7
(21 Views)