From Thursday, May 23rd (05:00 PM CDT) through Friday, April 24th (1:30 AM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

ni-daqmx driver for ubuntu 20

Hi everyone

I try to install de ni-daqmx driver on my raspberry pi 4 with is running ubuntu 20.4. Therefore I downloaded the NiDriverSoftware from https://www.ni.com/de-ch/support/downloads/drivers/download.ni-linux-device-drivers.html#350003. Then I followed the instructions for the ubuntu. 

scherpas_0-1617192904114.png

I worked until i wantet to install the ni-daqmx with the package mangerer. I got the following message from the consol.

scherpas_1-1617193222824.png

I'm quite new to this whole topic therefore I'd appreaciate your help. Can anyone help me out?

Thx

 

0 Kudos
Message 1 of 4
(2,278 Views)

I suspect NI drivers are not supported on that version of ubuntu. 

As it is indicated in below article daqmx should be available on 18.04 ubuntu. any chance you can try on that version?

https://www.ni.com/en-us/support/documentation/supplemental/18/downloading-and-installing-ni-driver-...

 

0 Kudos
Message 2 of 4
(2,213 Views)

Hi,I meet the same question with you. Have you solve the question? Have you change the ubuntu version?

Thank you.

0 Kudos
Message 3 of 4
(2,015 Views)

Have you tried without the hyphen? eg

apt install nidaqmx

(No comment on arm support, just to check the package name is correct)

0 Kudos
Message 4 of 4
(1,988 Views)