Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

ni-6224 ai0 doesn't read bat voltage; ai1 does

I've got an ni-6224 and an SCB-68. When I attach a D-cell battery's positive to pin 33, negative to pin 67, and read "Dev1/ai1" in RSE mode I get a steady 1.6 volts. But when I move the battery's positive to pin 68 and read "Dev1/ai0" in RSE mode I get fluctuations around 0.25 volts (actually, I can't see any difference when the battery is connected vs when it's not connected). I get the same results when I move to the other connector and try "Dev1/ai16" and "Dev1/ai17".

What's going on? What other clues can I provide?


0 Kudos
Message 1 of 2
(2,141 Views)

tsingle,

I would suggest that you try the DAQ Diagnostic Utility available here:
http://digital.ni.com/softlib.nsf/websearch/FEA4D55E1B3DA33A86257076006AA260?opendocument&node=132070_US

If this test passes the analog input test you might have a problem with your SCB-68.  If you are using the 6224 you should have two connector blocks (two SCB 68s).  Have you tried your second SCB-68?

If DAQ Diagnostic Utility reports any failures, or if you have tried the 6224 with different cables, and different SCB-68s the only other test you could try would be to put the card in another machine. If all of these tests fail, you probably have a problem with your card.   If you would like to talk to a customer service representative about having your card repaired you can call (800) 531-5066.

Regards,

Jesse O.
Application Engineering
National Instruments

Message Edited by Jesse O on 03-03-2006 02:05 PM

Jesse O. | National Instruments R&D
0 Kudos
Message 2 of 2
(2,120 Views)