Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

multiple record acquisition on 5911

Highlighted
Has anyone tried a multiple record acquisition on the 5911 in Win95 ?
The niscope_initiateacquisition function takes a long time to get going
(anything from a few ms upwards), which means I miss a lot of lines in
the image I'm trying to grab. Do I need to tell Windows to stop doing
anything else during my acquisition loop ? If so how ? I've tried disabling
interrupts (using Borland _disable(), _enable() functions), which improves
things a little bit, but the problem's still there.
0 Kudos
Message 1 of 2
(968 Views)
Hi David,

The first time you make a call to Initiate Acquisition will take a lot of
time because this is when all your configurations are sent down to the board.
I tried this here and found it took nearly 16 ms for this call and I have
a very fast machine (800 MHz).

It seems that you are starting your device and the NI 5911 at the same time.
Could you start the NI 5911 before your device? This way it will be up
and running and waiting for a trigger and you won't have to worry about this
delay.

In multi record acquisition, you only have to call the initiate acquistion
one time so after this call, the time between acquisitions will be very small
since it happens on the hardware and windows will not interfere.




"David Bell" wrote:
>>Has a
nyone tried a multiple record acquisition on the 5911 in Win95 ?>The
niscope_initiateacquisition function takes a long time to get going>(anything
from a few ms upwards), which means I miss a lot of lines in>the image I'm
trying to grab. Do I need to tell Windows to stop doing>anything else during
my acquisition loop ? If so how ? I've tried disabling>interrupts (using
Borland _disable(), _enable() functions), which improves>things a little
bit, but the problem's still there.
Message 2 of 2
(968 Views)