Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

multiple channel filter

Solved!
Go to solution

hello, i have another problem here, just started learning filtering and decided to practice on the task im doing, so got this one question: i have two signals on the input channels from two pressure sensors which come with high noise. i tried splitting the signals, filtering them and then merging them again to send to waveform, but it somehow didnt work, and i thought whether there was a specific filter for multiple channels, i read that some FIR can split signals within itself and them merge them automatically, but i couldnt find one. any suggestions for the novice? thanks in advance 🙂

 

p.s. by the way, managed to filter one of the signals split manually, and for some reason, the waveform displaying the pressure sensor data with noise stops working after apprx 3 sec, it kind of lags a bit and then goes blank black, if any suggestions on that, would much appreciate

 

p.p.s both waveform charts showing the initial data from the sensors go blank black after a while simultaneously 😞

______________________________________
i've got a rebel heart
Message 1 of 7
(4,911 Views)

I am not aware of any multi-channel filter VIs. For just two channels it probably makes sense to drop two copies of the filter VI on your blcok diagram.

 

As for your blanking issue, we would need to see your VI and some data. Please post what you have done. Can you reproduce the blanking effect with simulated data or does itonly occur with your data acquisition hardware? Also tell us what hardware you are using.

 

Lynn

0 Kudos
Message 2 of 7
(4,893 Views)

Hello, Lynn 

 

1. you mean to split the signal and then to merge it back? i've attached the .vi below

2. i use NI9269 as AO and NI9205 as AI, chassis module is NI cDAQ 9178

______________________________________
i've got a rebel heart
0 Kudos
Message 3 of 7
(4,851 Views)

Hello Pomplamoose,

 

You configured your Hardware to read 10kS/s and in Software its configured to read in 1 Sample per Loop Iteration (Software Timed). In this case your loop has to execute 10k times per second and that is impossible.So your Data in the buffer will be overwritten and that causes an error.To read data requires time but it makes almost no difference in time to read in a package of Data in one reading session. So you should choose to read in multiple Samples per Iteration. This can be done within the Read VI: Analog -> Multiple Channels -> Multiple Samples -> 1D Waveform.

 

This should help you with the Problem that your initial Data Chart is going to be blank after some seconds.

 

Attached you can find your VI with the change.

 

kind regards,

 

Markus Mayr

0 Kudos
Message 4 of 7
(4,819 Views)

thanks a lot, Markus! gonna check the vi as soon as i get back to working witht the DAQ stuff. by the way, did you check out the filtering part? maybe you could give me some advice on that too 🙂 thanks a lot!

______________________________________
i've got a rebel heart
0 Kudos
Message 5 of 7
(4,785 Views)
Solution
Accepted by pomplamoose

Hello Pomplamoose,

 

I forgot something to mention: If you set the reading VI to N samples you have to wire a constant to the Number of Samples per Channel Input. A good way would be to read in 1000 samples per Iteration.

 

Fliltering Part:

 

First of all, if you want to filter out high noise you have to use Lowpass Fliter.

 

Attached you will find your VI with 2 ways how you can filter your signals.

1) Easy solution with Filter express VI.

2) Butterworth Filter VI, the way you tried it.

 

Some explanation to 2):

If you use the butterworth filter VI as a Lowpass/Highpass Filter it ignores the high cutoff frequency input. The input you have to use is the lowcutoff freq.

In the VI I provide you there is no timing information in the signal after it is filtered, because you use only the Y Data from the Waveform type. If you want to have timing information in your signal you could do that with building a waveform typ after you filtered the Y Data.

Therefore you have no timing in the Signal you have to resize the chart that you can see the whole filtered signal.

 

To merge the Signals after you filtered them you have 2 ways:

1) Build an array from the outputs of the filters.

2) Use the merge signals VI.

 

If you need more help just ask, otherwise mark as solved.

 

kind regards,

 

Markus Mayr

 

 

 

 

0 Kudos
Message 6 of 7
(4,776 Views)

one couldn't be more helpful, thank you so much 🙂 

______________________________________
i've got a rebel heart
0 Kudos
Message 7 of 7
(4,763 Views)