Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

communication with digiforce over rs232

Hello!
 
I'm trying co communicate with digiforce 9310 over rs232 and i can't get any response. It works fine when I'm using their (Burster's) original program. Since now I never had problems with serial communication. I think the problem is that both sides have master status at start point.. and I don't know how to specify a slave station. any suggestion?
 
0 Kudos
Message 1 of 5
(2,368 Views)
Hello,

Are you communicating using NI-VISA or the Windows API? Do you get any specific errors? I suggest trying hyperterminal to see if you can get a response from there. You could also download portmon (a serial port monitor), to see what the Burster's program is sending to the port, and perhaps that will give you an idea of what to do. Hope this helps.

Regards,
Ebele O.
National Instruments
0 Kudos
Message 2 of 5
(2,342 Views)
I chacked out some threads about using rs232 and already solved the problem. anyway..thank you for your suggestions about using portmon. .useful reply.

0 Kudos
Message 3 of 5
(2,332 Views)

Hello i have the same trouble to communicate a digiforce via rs232 and

could you explain me what you did to solve that problem please? 

0 Kudos
Message 4 of 5
(1,956 Views)

Hi montañanevada,

 

could you please specify, if you are getting any errors, so we could try and find out, where the actual issue is taking place?

 

Thanks and have a great day!

Best regards,
Jano
0 Kudos
Message 5 of 5
(1,937 Views)