Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

cDAQ differences in AO and AI measurement

Hello everyone

 

I am using following setup: NI cDAQ 9174,NI 9234 (AI) and NI 9269 (AO). The Matlab data acquisition toolbox is used with DAQmx.
In the most simple case an analog output is placed over a resistor of 1kOhm and at the same place the voltage is measured by the analog input card.

The signal is a chirp cosine (sweep) with an amplitude of 1 V that increases in 30 s from 1 kHz untill 25.6 kHz. This maximum here is half of the samplefrequency (51.2 kHz). The problems I experience are visible in the attached PDF. Also the code to generate and measure the signal is added.

 

There is a fixed delay in the beginning of the measurement. When the frequency increases, the amplitude decreases (this is not the case when measured with an oscilloscope). Also there is some strange behaviour at the end of the measurement (even far from the maximal value). In this way I cannot rely on the defined output, and I always have to measure it as well.

 

Is it possible to explain these effects by for example some kind of low pass filter that is not mentioned in the datasheet or a feature of the BNC cable itself? The amplitude difference worries me the most.

 

Thanks in advance

Download All
0 Kudos
Message 1 of 5
(757 Views)

Since you have a simultaneous sampling AI, I would always do a 2channel aquisition and read the AO back. (and if you use the same range, you can swap the channels, repeat you measurement and compensate the linear gain/ phase errors between both channels 😉 )

 

However it looks like you don't start both tasks (AO and AI) at the same time. Have a look at the examples on how to do that and/or post your vi.

 

 

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 2 of 5
(717 Views)

Hello

 

I am not using LabView, but Matlab. The synchronization is a minor problem and cannot be solved according to what I find online.

The main question is why the amplitude decreases for increasing frequency. I use 1 channel on the AO card to generate the signal and 1 channel on the AI card to measure the same signal (over a resistor).

 

Thanks in advance

0 Kudos
Message 3 of 5
(710 Views)

Oh, the frequency response.. well you measure complex impedances ..

different setups  , different  cable capacities ..different input impedances.. 

 

And why not read two channels ?

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


0 Kudos
Message 4 of 5
(702 Views)

I indeed measure the voltage drop over a real resistor. The setup stays the same. It is possible that the internal voltage drop increases because of the frequency (the capacitance/inductance is dependent on the frequency). But when measured with an oscilloscope this decrease in amplitude is not seen. What would I measure with the second channel?

0 Kudos
Message 5 of 5
(696 Views)