Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

cDAQ 9191 communication problem with the computer

I have a cDAQ 9191 Chassis, with a cDAQ 9215 Voltage Module, connected directly to the computer using an Ethernet cable.

This has been working fine for months, and now for no apparent reason, the computer and the module won't communicate.


I have tried going back through the setup instructions, but nothing has worked so far to re-establish the connection.

The computer recognizes when the Ethernet cable is hooked up, but the "General Settings" window under System Settings shows the System State as "Disconnected", and the module Icon has a little Red X on it.  Self Test, Refresh, and Reconnect are ineffective in correcting this.


Any help with re-establishing communication between the computer and the chassis will be Greatly appreciated.

0 Kudos
Message 1 of 5

Greetings PSIALong


Has your computer undergone any OS updates recently? Is it running an anti-virus, firewall?

What version of MAX, DAQmx, Operative System are you running?

What happens if you delete the device in MAX (while the device is disconnected) and connect it again?

Are the lights on the chassis lit?

Do you have access to another computer? Can you try to connect on that computer?


Please give us more information in order to troubleshoot better this issue. Have a good day. 

Luis J.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 5



The computer has not undergone any OS updates recently, other than what might have updated automatically.


We are running Version 5.3.2 of NI Max.


If the device is deleted in MAX and then connected again, the "Find Network Devices" screen says "No Devices Found".

The "Local Area Network" that the chassis is connected to says "Connected, Shared", but the device is not being recognized.


The Power and Status lights are on all the time.  The "Status" LED does not go off the way it is supposed to, indicating that the firmware is not properly uploading.


We have only one computer with the NI software on it.  We cannot try connecting to a different computer.

0 Kudos
Message 3 of 5

Greetings PSIALong


The following document has an extensive list of troubleshooting steps that might be of help in solving this problem.


Follow each step and tell us if the problem disappears.

If the issue is not solved, remember that the DAQmx driver is free and can be downloaded from the National Instruments website. The latest version can be found here:


The driver includes NI-MAX so if you install the driver in another computer and can recognize the device in MAX, it will give us some insight on what is happening.

Luis J.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 5

Hi PSIALong-


Before you go to the trouble of updating your NI software, you might want to try the steps outlined in this KB:


The solid Status LED is troubling, and, as you mentioned, seems to indicate a problem with the device.  You can often recover from that state using the steps in the KB I linked previously in conjunction with the utility described here:



Hopefully this helps-

Tom W
National Instruments
0 Kudos
Message 5 of 5