Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

cDAQ-9188 cannot be reserved, Also the "set permission" and " log in" is always grey out....too many questions are waiting for me

Hi Jerry:

      Thanks. I did add it in. I found it in the list and then added it in (I probably should send you a better screenshot because the one I showed you look like I didn't). Cannot do the self-test either.

Screenshot (1).png

        Also, I found in the manual, NI-DAQmx should be the only driver for cDAQ chasis. I am wondering what can be wrong

Screen Shot 2022-01-28 at 4.47.22 PM.png

       I also followed the link's suggestion to make sure the NI device loader started, but nothing changed. 

Screenshot (2).png


       I even tested it on a new Windows computer.

Can you give me more suggestions on it, Jerry?






0 Kudos
Message 11 of 18

From your screenshot, NI Device Loader service seems to be running. But we are back to the original problem, it looks the target is unreachable again.


  1. Can you open a command prompt and use the ping command to ping your cDAQ-9188 @ the IP address shown in MAX? Ping checks basic network communication with a network device. cDAQ-9188 has to respond to pings from your host PC for it to communicate with your host computer.
  2. If the cDAQ-9188 is responding to pings, then double check your firewall to make sure all the ports that cDAQ-9188 needs are open for inbound and outbound traffic or just disable your firewall for an experiment and try to use it in MAX.
  3. If the cDAQ-9188 is not responding to pings, then leave the cDAQ-9188 connected to your PC and power cycle by removing and reapplying power. You said that you moved it to a different computer. I don't know if you power cycled the chassis after moving computer, because it would only fall back to link local on boot. After power cycle, the cDAQ-9188 should have a different link local address. Check it in MAX and try to ping it again. If it is still not responding to pings, then you might consider setting your Ethernet interface to the static IP as suggested in that knowledgebase article and try pinging the cDAQ-9188 again.


Another option you can try if you have a router that has a DHCP server enabled is to connect the cDAQ-9188 to your router. Power cycle the cDAQ-9188 and let it get an IP address from your router. And then if your computer is connected to the same router, it should be able to discover the cDAQ-9188 in MAX.

Message 12 of 18

Hi Jerry:
   It is me again. I tried to use the command "ping" but I cannot interpret them. I am not sure whether the round trip times are almost 0 means no connection at all. 

Screen Shot 2022-02-02 at 7.50.50 PM.png

I just turned off the firewall directly and restarted the computer and deleted the device and readded it again. 

But still, it says, "The device is not reachable"

Screen Shot 2022-02-02 at 7.58.22 PM.png


I have a router but it belongs to university property. I have no idea whether the school network will make this become even more complicated. Since the school network needs an account/password to log in. But I will consider somehow getting one....


Again, thank you, Jerry. Thank you for not giving up on me. : )





0 Kudos
Message 13 of 18

The ping result is good. That means the device responded quickly with no delay. That means the network path between the host computer and the cDAQ-9188 is fine. Well, to be honest, at this stage I am running out of ideas there.


Just to double check one thing, your host computer only have one network interface, no wifi? If both wifi and ethernet exist and are enabled on your host computer, it could be a multi-home problem. You can try to disable your wifi and see if that changes anything.


The only other thing I can think off is to try to access the web server on the cDAQ-9188 to see if it is reachable from your browser: (

Configuring CompactDAQ Ethernet or Wireless Chassis Through a Web Browser section from 

Installing and Configuring CompactDAQ Chassis - National Instruments (

  1. Install Microsoft Silverlight on your host computer for free from
  2. Open a web browser (Internet Explorer, Mozilla Firefox, or Google Chrome), and enter the IP address of the cDAQ-9184/9188/9188XT/9191 chassis into the address bar and click Enter.


After the web server loaded, you can query the firmware version for the cDAQ-9188. If the one on your cDAQ-9188 is old, you can try upgrade it to the latest one and see if it works better: Firmware Information for NI CompactDAQ Network Chassis - NI.


Message 14 of 18

Hi Jerry:

        Thank you for your help all along. It took me several days to decide finally to give up on it. 

        Yes. I only got one Ethernet port on my computer.

        The NI network browser is using an extension called Silverlight(just like Flash), which the company is already broken. And also, it has to be opened in Internet Explorer, which is ending in June 2022.......(it is like the whole world is against me to set up the DAQ system.....)



        Also, Silverlight right now requires an operating system for Windows 7. It's really to find an old computer right now.

When I somehow got an old computer, I downloaded the Silverlight but it didn't work at all. It said it has to restart the browser to be used. I even restarted the old computer but it still cannot be used(still said I need to restart the browser to be used). I think it could be the Silverlight is out of maintenance.



Screen Shot 2022-02-10 at 2.59.29 PM.png


       I think I probably either need to ask for my advisor to repair it or buy a new one. Also, I just knew that the last time that the DAQ-9188 was used was 11 years ago. Maybe it is a too old device to be used.


        Sorry for the late reply. Thank again.  : )




0 Kudos
Message 15 of 18

That is unfortunate. Maybe one last try you can do is to try a different Ethernet cable? Because it sounds like the cDAQ-9188 is mostly working, but the network communication with the cDAQ-9188 and your host computer is having problems.


Well, good luck, sorry that it didn't work out.

Message 16 of 18

Hi Jerry:
        I tried several cables and also different types. We have Non-cross-over and cross-over Ethernet cables in the lab. But they has the same result: the device is not reachable"  The reason I believe the cable is okay is that when I removed the cable, the software cannot even find the device...

       I think you really helped me a lot. 

       I am going to send the device back to the National Instrument for repair, but I am not sure whether they will just check the hardware and cannot fix my software communication issue. Do you happen to know this? 


0 Kudos
Message 17 of 18

Well, pings did work between your host computer and the cDAQ-9188. So there is basic network communication. However for the driver software to be able to communicate with the cDAQ-9188. All the following ports has to be open between your host computer and the cDAQ-9188 as I mentioned previously:

  • HTTP:80 (configuration only)
  • TCP:3580
  • TCP:31415
  • UDP:5353(configuration only)
  • TCP: 5353(configuration only)
  • UDP:7865 (configuration only)
  • UDP:8473 (configuration only)

My guess is that one of these ports is not working, that is why the driver software cannot find the cDAQ-9188.


Have you tried these steps from Troubleshooting Network cDAQ Connectivity Issues - NI?

  • Try disabling any anti-virus software, it may be interfering with the discovery or configuration process.
  • Disable any Virtual Machine network adaptors such as VMWare. These adaptors can route traffic incorrectly and cause the cDAQ to not be discovered or used.
  • If working through steps 1-12 does not result in finding and configuration your cDAQ try factory resetting the chassis. To do this hold down the Reset button for more than 5 seconds and then release it. This will change all the network configuration settings to default.


Is the LED on the cDAQ-9188 blinking in sets of 3 or has a solid yellow status light,? You can try to recover the cDAQ-9188 yourself by forcing it into recovery mode and use the recovery utility from NI.


0 Kudos
Message 18 of 18