Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

cDAQ-9188 cannot be reserved, Also the "set permission" and " log in" is always grey out....too many questions are waiting for me

I have too many questions that I don't even know which one I should start...

The story began on that I have borrowed a DAQ-9188 from York College, CUNY.  I am testing it at Purdue University. 

In the beginning, the software can recognize my DAQ9188, but it says " this device is not reachable". I thought it was because I didn't reserve the Chasis. So I followed the DAQ manual and try to reserve it but there is no reserving option showing up. Also, my "set permission" and "log in" are always grey out. I reset the configuration, right now, it cannot even find the network adapter. 

Please help me from the DAQ chasis....   : (

(The software I use for NIMax is 21.3.0) 




0 Kudos
Message 1 of 18

From the MAX screenshot, it shows that a cDAQ-9188 was once added to your system, but it is not reachable at the moment. Resetting the configuration does not help in this case. Ethernet cDAQ has to be on the subnet as the host computer for it to be automatically discovered. If it is not on the same subnet, then you have to know its IP address to connect to it. If you have the cDAQ-9188 in front of you, you can also connect it to your host computer directly. If it powers up while directly connected to the host computer, it will get a link-local address.


So do you have cDAQ-9188 in front of you? Or is it sitting in a lab somewhere that you are accessing remotely? How is it connected?

Message 2 of 18

Hi Jerry:
     Thank you for your reply. I did connect the DAQ directly with my computer with the Ethernet cable. I have it in front of me and also I didn't control it remotely.

       So I should do it next?

       Again! Thank you for saving my life. : )

0 Kudos
Message 3 of 18

If you have it connected directly to your computer with the Ethernet cable, it should come up with a link local address if your computer is not running a DHCP server. It usually takes a while (20~30 seconds) for the cDAQ-9188 to get the link local address. That is the cDAQ-9188's default behavior anyway. If you are not sure what network configuration that cDAQ-9188 has, you can factory reset the cDAQ-9188  by holding down the reset button for more than 5 seconds. This will put the device in to a default state and configuration. The default behavior is looking for a DHCP server first. If not found, then fall back to link local.


This is a good guide to trouble shoot connectivity issue with Ethernet cDAQ: Troubleshooting Network cDAQ Connectivity Issues - NI.


I am going to call out some steps to help you debug.

  1. Delete the existing cDAQ-9188 chassis item from MAX
  2. Leave the Ethernet cable connected between your PC and cDAQ-9188, power cycle the cDAQ-9188.
  3. Wait 30 seconds and then try finding it in MAX by right-clicking on Network Devices and select Find Network NI-DAQmx Devices.
  4. If your PC discover the cDAQ-9188, then great. You can just re-add it to your system. if not, then it is onto the next step.
  5. Setting the Ethernet interface whom the cDAQ-9188 is connected to have a static IP address, 169.254.X.X, with the subnet mask will ensure that the device and your computer are on the same subnet
  6. Wait 30 seconds and then try finding it in MAX by right-clicking on Network Devices and select Find Network NI-DAQmx Devices.

In the trouble-shooting guide above, it list the ports that have to be open for the Ethernet cDAQ to function correctly. You should make sure that your firewall have these ports open to the cDAQ-9188. For experiment, you can just disable your firewall briefly.

  • HTTP:80 (configuration only)
  • TCP:3580
  • TCP:31415
  • UDP:5353(configuration only)
  • TCP: 5353(configuration only)
  • UDP:7865 (configuration only)
  • UDP:8473 (configuration only)


If your computer has more than on network interfaces, you should also consider disabling other interface and leave just the interface that is connected to cDAQ-9188 enabled while troubleshooting. For instance, if both WIFI and Ethernet is enabled on your computer, then that would be a multi-homing network. That sometimes causes network discovery problems.

Message 4 of 18

Hi Jerry:
       Thanks for providing me with a lot of useful information. I tried to follow the instruction you showed me. 

It seems like I got the Network adaptor but not Wireless connection. I opened the static port in Window firewall for TCP/UCP.

Also, one more good thing is that I can click the "log in" and "set permission". Although I don't where to get the account and password to log in. 

       Thank you. 

Download All
0 Kudos
Message 5 of 18

Looks like it is mostly working now, to use the cDAQ-9188, you just have to click add device and then reserve it to use it.


You only need to log in if you need to change cDAQ-9188's network configuration. By default, it should be as described in this table below.

Default Network cDAQ Configuration
Attribute Value


cDAQ<model number>-<serial number>


DHCP or Link Local



NI Auth

User name = admin
Password = no password required

Message 6 of 18

Hi Jerry:
       Thank you for your fast reply. I did try to add the device but I still cannot reserve it. I made sure my host computer iPV4 properties are set to" obtain an IP address automatically" ( I also tried to use the IP address with and subnet" ).

Screenshot (42).png

I can add the device but still, there is  no option for reserving and the self-test is grey out

 (attached screenshot)

Screenshot (41).png

I deleted the device and tried to add the device again but not help. 

              : ) 

0 Kudos
Message 7 of 18

Ah, I see, you can see the device over the network now, but you cannot reserve it or perform driver operation on it.


It looks as if the DAQmx driver is not installed or not running. Have you checked in device manager that NI driver is associated with the cDAQ-9188, make sure NI device loader service is running, and check there is no error in Windows event log regarding starting NI drivers.



0 Kudos
Message 8 of 18

Hi Jerry:
       Thanks.  😅I didn't remember whether I installed the NI drivers so I just installed one. But still, there is no sign of reserving. Even if I open the NI max at the NI Launcher app.

     When you said "checked in device manager that NI driver is associated with the cDAQ-9188," did you mean NI device monitor"?  It showed that " No NI device detected" at the right bottom corner.

Screen Shot 2022-01-26 at 5.14.00 PM.png

I hope I installed the NI device drive right. I just hit install and then reboot my computer.

Screenshot (44)[34].png

Hope you have a nice day


0 Kudos
Message 9 of 18

Before you can reserve it, you have to click on add network device to add it to the system. Then you can reserve it. Trying doing that. I see that self-test is not greyed out anymore, you can click on self-test to check if there is any communication between the driver and the cDAQ-9188.


By device manager, I am referring to Windows Device Manager. And you can check whether NI Device Loader service is started by following the instructions here: Error -88705 or 80040383 with DAQmx or GPIB Device in NI-MAX - NI.



Message 10 of 18