Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

cDAQ 9185 and NI9205/9476 module

Highlighted

Hi Everybody,

 

 

I am running into some problems with the cDAQ 9185 when using it with labview 2015. When using the DAQ assistant and configuring the cDAQ for voltage input, I get the message error code 209836, and this means that the devices in my task can not be synchronized. When self testing the pannel and the seperate module in NI MAX I get the message that the self test was successful, but when I try the testing panels to see if I get them to work I again get an error message "Error - 209836 occured at daqmxcfg_DAQmx Start Task.vi:4410001" Which again as possible reeasons gives that the task can not be synchonized. Has anyone encountered this problem before? I have updated the software on the cDAQ and I am running the NI-DAQmx version 18.0. 

If anyone can help or needs some more information, let me know!

 

Thanks in advance,

 


Kind regards,

 

Jeroen

0 Kudos
Message 1 of 6
(448 Views)

 Hello JerPee,

 

Could you please tell more about

  • your overall application
  • software setup and
  • what is the hardware you are trying to synchronize?

I would also appreciate it if you could post the VI so I can take a look at the code itself. With more context it is easier to determine where the problem may be. To generate MAX System Report please follow the instructions here: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8KZSA0

 

Best regards,

Lassi

0 Kudos
Message 2 of 6
(416 Views)

Hi Lassi, 

 

 

Thanks for replying!

My overall application is gathering data under the form of voltage signals out of a self build module (NI 9205 C series module), and eventually to also control this module via LabVIEW (the module consists of solenoid valves and other components that can be controlled via a self build relay board which in turn can be controlled by the NI 9476 C series module).

The software I use is LabVIEW 2015, NI-DAQmx 18.0, Software on the cDAQ9185 is 17.6.1f0, I am running Windows 8.1 Pro.

The hardware I am using is the NI cDAQ 9185 (4 port compact DAQ), with the NI 9205 AI card and NI 9476 DO card.

As for the LabVIEW file I want to use it with (see attachments): I know there probably are a lot of thing that could be done better, but given that I am working alone on designing, building, testing, installing and programming the module and with my limited knowledge of LabVIEW, this is the best I could do at the momentSmiley Happy

 

Kind regards,

 

Jeroen 

 

And this is the system report:

 

Operating System(OS) Windows 8.1 Professional
OS Version 6.03.9600
OS Info
Processor Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz / Intel64 Family 6 Model 61 Stepping 4 / GenuineIntel / 2295 MHz
Number of Processors 4
Physical Memory 7,89 GB of RAM
Drive C:\ 19,4 GB of 237 GB free

National Instruments Software: Version:

CVI Runtime 17.0.0.295
NI-DAQmx Device Driver 18.0.0f0
NI-DAQmx ADE Support 18.0.0
NI-DAQmx MAX Configuration 18.0.0
NI I/O Trace 18.0.0f0
LabVIEW Runtime 2012 SP1 f9 12.0.1
LabVIEW Runtime 2016 f5 (64-bit) 16.0.0
Measurement & Automation Explorer 18.0.0f0
Measurement Studio Visual Studio 2010 Support - See individual versions below.
DotNET
Common 15.1.40.49152
Common (64-bit) 15.1.40.49152
NI-USI 17.0.0.6654
NI PXI Platform Services Configuration 18.0.0f0
NI PXI Platform Services Runtime 18.0.0f0
NI-PAL Software 18.0.0
NI 1588-2008 Network Management 18.0.0 18.0.0f0
NI-Serial Runtime 15.0.0f0
NI-Serial Configuration 15.0.0f0
NI System Configuration 18.0.0f0
NI-VISA 18.0
NiVisaServer.exe 17.5.0.49152
NIvisaic.exe 18.0.0.49152
NI-VISA Runtime 18.0
LabVIEW 15.0.0
Database Connectivity Toolkit 15.0.0
Real-Time 15.0.0
Real-Time Trace Viewer - LabVIEW 2015 Support 15.0.0
Report Generation Toolkit For Microsoft Office 15.0.0
LabVIEW 16.0.0
Database Connectivity Toolkit 16.0.0
Report Generation Toolkit For Microsoft Office 16.0.0
LabVIEW 17.0.0
Database Connectivity Toolkit 17.0.0
Report Generation Toolkit For Microsoft Office 17.0.0
LabVIEW Runtime 2013 SP1 f6 13.0.1
LabVIEW Runtime 2014 SP1 f11 14.0.1
LabVIEW Runtime 2015 SP1 f10 15.0.1
LabVIEW Runtime 2016 f5 16.0.0
LabVIEW Runtime 2017 SP1 f3 17.0.1
LabVIEW 2016 f5 (64-bit) 16.0.0
Report Generation Toolkit For Microsoft Office 16.0.0

 

0 Kudos
Message 3 of 6
(411 Views)

Hello Jeroen,

 

Thank you for the details. What steps have you already taken to troubleshoot the issue? Has there been any update since you posted the question?

Best regards,

Lassi

0 Kudos
Message 4 of 6
(367 Views)

How did you solve the problem?

0 Kudos
Message 5 of 6
(90 Views)

I haven't solved it yet, still working on it:s

0 Kudos
Message 6 of 6
(87 Views)