Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

cDAQ-9181 ethernet connection problem

Hello,

 

I have a connection problem with a cDAQ-9181 ethernet chassis. After connecting it to the network none of the lights on the ethernet port lits up. Device's power led is green and status led is off. I tried to reset the configuration by pressing the reset button, status led lit up then turned off but the problem continued. 

 

The ethernet cables that I tried don't have any problems, they are working perfectly with other NI equipment except this specific device. It seems there is a hardware malfunction on the ethernet port but does anyone has any suggestion for fixing the problem before sending the device for RMA.

 

Kind regards,

Ugur

0 Kudos
Message 1 of 4
(1,707 Views)

Hi Ugur,

 

Are you able to see your DAQ device in NI MAX?

 

There are some troubleshooting steps in the tutorial Troubleshooting Network cDAQ Connectivity Issues that you can try.

 

Here's the manual for cDAQ 9181: http://www.ni.com/documentation/en/compactdaq-chassis/latest/cdaq-9181/pinout/. In the manual it states that when the status LED is off, the cDAQ is undergoing normal operation.

 

You might also find the following knowledge based article useful: Fix Blinking Status Light for Ethernet cDAQ.

 

Best,

Misbah

Applications Engineer

National Instruments

0 Kudos
Message 2 of 4
(1,650 Views)

Hello Misbah,

 

Thanks for the answer.

 

No, I can't see it on NI MAX. I checked ethernet port lights on the router and they also did not lit up. So, I think there is a problem with the ethernet port of the chassis. Since the port is the only way to communicate with the device, I think, I could not do anything by myself (re-writing firmware etc.).

 

Ugur

0 Kudos
Message 3 of 4
(1,648 Views)

Ugur,

 

Are you able to see the device in your device manager? If not, you may be correct about there being a problem with the ethernet port. You can try the following troubleshooting steps:

 

Try disconnecting and reconnecting the cDAQ from the computer.

 

Make sure you are using a standard Ethernet cable and not a crossover cable. A standard Ethernet cable should also be used even if connecting directly to a PC and not through a router.

 

NI-DAQmx is the required NI driver to use your cDAQ chassis.  Use NI MAX to check the version of NI-DAQmx installed on your system (https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8dMSAS). Ensure that the version of the NI-DAQmx driver installed on your system supports your chassis (http://www.ni.com/nisearch/app/main/p/bot/no/ap/tech/lang/en/pg/1/sn/catnav:du,n8:3478.41.181.5495,s...).

 

Try factory resetting the chassis. To do this hold down the Reset button for more than 5 seconds and then release. This will change all the network configuration settings to default.

 

Best,

Misbah

0 Kudos
Message 4 of 4
(1,633 Views)