Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

application failed to initialize properly Oxc0000005 with Ni-Daq 7


I found several posts related to my problem, but none of them solved it, so i hope i didn't overlook the right answer..

We have some self-written applications using theNidaq dll's. Before, with the 6.9 drivers everything worked fine, but now we have a new computer (an Acer Travelmate 4670 with WinXP professional - i'm logged in as administrator), and we can't use the 6.9 drivers anymore (they give a "device not responding to the first IRQ level" error, and i found somewhere on this board that the only solution was to upgrade the drivers).
But now with the new drivers (i tried 7.0 as well as 7.4.1 and un-and reinstalled both a couple of times allready), our applications fail to start wit the message "application failed to initialize properly Oxc0000005".

i tried to solve it with palBase, but that failed. Hereunder i paste the results of running palBase:

C:\WINDOWS>palBase -b 64000000 -s 44000000

PALBase version 1.0
(c) Copyright 2001-2002
National Instruments Corporation

Rebasing: "C:\WINDOWS\system32\nipalu.dll"
Old Base: 0x0
New Base: 0x64000000
ERROR: SDK call ReBaseImage failed with error: 1
GetLastError() reports error: 32
Verify that "imagehlp.dll" is in your path or proper Windows system directory.

Verifying that NI-PAL 1.5.6 or higher is installed.
PAL Version Confirmed.
Shared Memory sucessfully set to 44000000


the imagehlp.dll is actually under my c:\windows\system32 directory (i did run the palBase from under c:\windows\)

any ideas what is going wrong and how to solve it?


0 Kudos
Message 1 of 2
The output you posted is from palBase version 1.0.  I would recommend palBase version 1.2 that is attached to the following NI KnowledgeBase:
2Q1HG8A6 "Unusual Error Messages Loading, Executing, or Debugging an Application When Using NI-DAQ for Windows" link

Perhaps file locking is preventing you from rebasing NI-PAL?  You might try the following:
Rename "nipalk.sys" to "nipalk.bak"
Run palBase
Rename "nipalk.bak" back to "nipalk.sys"
Reboot and test your software

If that does not work, I would strongly encourage you to see if your hardware is supported in NI-DAQmx (link) (link), or consider acquiring some DAQmx hardware.  Otherwise, you may consider reverting to an older laptop (think hardware that was similar to what we tested when your NI hardware and software was designed and tested).

Hope that helps!
0 Kudos
Message 2 of 2