Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

analog out split to analog in and another device: ground loop?

I'm using a 6052E card to generate analog output from a BNC-2090.  This output is going to an amplifier but I would like to send a copy of it back in to one of the analog input channels for acquisition.  So I "T" the analog output and send one side of the T into ACH0 of the same 2090.  This works fine - I can see the signal on ACH0.  However, when I send the other side of the T to my amplifier (the destination of the signal), a 5-10 mV offset appears on the signal recorded on ACH0.  Connecting the amplifier directly to ACH0 does not show any offset, ruling out (I think), the simple ground loop between the acquisition PC and the amplifier.  Offsets of various levels are produced by almost anything I plug into the other half of the T, including the EXT REF of the same 2090.  However, plugging the other half of the T into any of the other analog in channels on the BNC-2090 is fine.

In short, I only see the offset, which I'm assuming is a ground loop, when the analog out goes back to the analog in _and also_ to some other device or to the EXT REF of the breakout box.  AO0 to ACH0 in is fine by itself, and other device to AO0 is also fine, but not the combination.  I would really like to understand why this is and would appreciate any help.  I've diagrammed the situation in the attached file.

thanks very much,

Gene
0 Kudos
Message 1 of 10
(3,925 Views)
How are your input channels configured? Differential or single-ended? And how about the configuration switches on the 2090? Those switches affect grounding.

Also, are you aware that you can read the analog outputs with the analog input without an external connection? You just have to enter the right channel string, which I can't remember at the moment.

Chris
0 Kudos
Message 2 of 10
(3,901 Views)
hi Chris -

Re: grounding configuration, I removed the W1 jumper on the 2090 and grounded the chassis to the rack, so my understanding is that the PC's ground is out of the picture now, which I was thinking of as a good thing.  I will check the input configuration and get back to you.

I was not aware that the AO-AI connection could be made internally - thanks for the tip!  You mention entering a channel string - do you mean in Labview?  I'm using Igor Pro from Wavemetrics so I'll have to see if they've enabled this functionality.

Gene
0 Kudos
Message 3 of 10
(3,888 Views)

Hello,

I am also interested in the channel configuration.  What are the switches on the 2090 set to NRSE, RSE, or DIFF?  The link provided below paired with your channel configuration will lead to a better understanding of the offset issue.  I am also interested to know how your grounds are setup.  The DAQ card / 2090 and amplifier (floating) should have the same reference to ground to prevent ground loops.  I realize that you have removed the W1 jumper, however that is just preventing ground loop current from being carried to the DGND.  The D stands for digital and does not relate to this analog setup.

 

Please look at Table 1 in the link below.

 

Field Wiring and Noise Considerations for Analog Signals

 

Samantha
National Instruments
Applications Engineer
0 Kudos
Message 4 of 10
(3,859 Views)
I'm very grateful for the replies so far.  I've done some further testing and have more information.

The input channels are configured as differential.  The analog out is set to NRSE.

The problem can be stated more simply than I originally stated it:

I have a loop going from DAC0 to ACH0 on a BNC-2090 connected to a 6052E.  I am sending a 250 mV square pulse ranging from 0 to -250 mV.  Anything T'ed out of that loop which is connected to the building ground causes a ~30 mV offset in the recorded ACH0 signal.  However, connecting "building grounded" instruments to other ACH channels does not cause the offset.  This last part is confusing to me.

I don't understand why the building ground is a problem when inserted into the DAC-ACH loop, but not when sent into a different ACH.  I also don't understand why the building ground is a problem at all, since the DAQ board is presumably grounded through the PC to the same building ground.

Thanks in advance for any assistance!

Gene
0 Kudos
Message 5 of 10
(3,835 Views)
There is no NRSE for analog out, so I'm not sure what you meant by that. AO is single-ended.
Since the AI is differential, AI ground doesn't come into the picture. You form a ground loop when you connect the AO ground to your grounded load (amplifier). I don't know why you don't notice the offset when the AI is disconnected, but connecting the AI should not affect the ground loop if you have your 2090 switches set correctly.

The reason building ground is a problem at all is that some currents (e.g. from the computer, or from the 6052E, or from your amplifier) flow through the ground connections, which have nonzero resistance. Thus a voltage develops on the ground terminal, and that voltage is different for each device. When you connect two devices that have different ground potentials, the potentials are moved closer together, but can't become exactly the same unless the resistance connecting them is zero. The DACs on the 6052E should have low offset with respect to the AOGND pin at the board's connector, but there's a lot of resistance in the cable connecting that pin to the corresponding BNC on the 2090. You could try running a separate low-resistance wire between the 2090 chassis (or some other ground, like DGND) and the ground of your amplifier. This should bring your grounds closer together without forcing a bunch of current through your signal ground connection.

HTH,
Chris
0 Kudos
Message 6 of 10
(3,830 Views)
Thanks, Chris (and others).  I saw the NRSE/RSE switch next to the DAC0/DAC1 ports and assumed it referred only to them.

I think you are right that the loop is between AO ground and my other instrumentation and so I need to find the most direct way of connecting them.  Is there any way to directly access the AOGND pin at the board's connector?  Or maybe I could switch to the 0.5 m version of the NI cable (it's 1 m right now).  How about moving the AC plugs of the PC and other instruments so that they are as physically close together as possible?  Is there anything I can do to the PC's power supply or internals to decrease the resistance between the card and the wall?

On the spring terminal block of the BNC-2090 I have DGND1, DGND2, and GND.  Using a simplified instrumentation loop of just a single patch clamp amplifier plugged into the wall, I can cut the offset in half by connecting either DGND1 or DGND2 to the amplifier ground.  Connecting the chassis to the amplifier ground doesn't help so much.  Are the DGNDs connected to each other and to the chassis?

thanks so much for all the help,

Gene
0 Kudos
Message 7 of 10
(3,803 Views)
All of your ideas could help. I don't think there is a direct connection to the AOGND terminal that isn't shared by the analog output you're using. You could use the AIGNDs, which should be very close in potential to the AOGNDs. AIGND is on the shell of the BNCs on ACH8-ACH15 on the 2090. Sharing a wall outlet (or as near as possible) ought to help. I don't think there's anything you can do inside the PC to help.

If you have a spare AI channel, you could measure the AO differentially at the load (amplifier) to measure the signal that the amplifier actually sees. You could use that to compensate in some way for any residual offset that you're unable to eliminate by other means.
0 Kudos
Message 8 of 10
(3,798 Views)
OK, I have some new information.

I shortened the NI cable from 2 meter to 1 meter.
I plugged the PC containing the 6052E and the single amplifier into adjacent sockets on the same receptacle.
I connected DGND1 and 2 on the spring connector block of the BNC2090 to the amplifier ground.

With all these changes, the offset is still only reduced to 25-50% of the 50 mV that it was at the start.

But, I was able to get rid of the offset entirely by using BNC cables with the shields broken to prevent the grounds from colliding.  Is this an acceptable strategy?  Everything is still grounded to the main power so I don't think it's dangerous, but it seems like an extreme solution and it's hard for me to believe that it's necessary.
0 Kudos
Message 9 of 10
(3,749 Views)

@Gene Civillico wrote:
But, I was able to get rid of the offset entirely by using BNC cables with the shields broken to prevent the grounds from colliding. Is this an acceptable strategy? Everything is still grounded to the main power so I don't think it's dangerous, but it seems like an extreme solution and it's hard for me to believe that it's necessary.

thanks very much,

Gene





That doesn't make any sense to me. I can see how that would keep any offset from showing up on the AI channel, but I would think the amplifier would see an even bigger offset now, since it's assuming (excuse the anthropomorphism) the signal you're sending it is referenced to its ground, which is now probably even more than 50mV removed from the actual AOGND to which the AO signal is referred.

If it works for your application, great, but don't assume that because the voltage is correct at the 2090 that it's correct where you're actually using it.

Chris
0 Kudos
Message 10 of 10
(3,745 Views)