Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Windows XP does not boot after installation of NI-DAQ 7.3 and 8.0, Dual Xeon PC

After installation of NI-DAQ 7.3 or 8.0 on a Dual Xeon PC (Tyan thunder 2676 mainboard) without PCI plugin cards (should be added later), and windows XP SP2,  the PC reboots during windows startup, and runs only in safe mode.
0 Kudos
Message 1 of 6
(3,030 Views)
Hi WLangbein,
 
Could you clarify the DAQ version that you have installed.
 
Also have you got another PC with DAQ on it? If so what version?
Have you tried running the same version of DAQ on another PC to eliminate the possibility that this is a PC problem rather than an installation issue?
 
Thanks
 
Emma rogulska
NIUK & Ireland
 
0 Kudos
Message 2 of 6
(3,009 Views)
The effect is that in the early startup phase of Windows XP (about 1-2 seconds after the startup screen appears),
the system reboots spontaneously.

This problem appeared after installation of NI-DAQ 7.3, which whas part of the Labwindows 7.1 package,
and (after deinstalling all NI software) also for NI-DAQ 8.0, which was delivered with the DAQ Board I bought.
I also tried DAQ 8.1 downloaded from the NI website - same problem.
I installed the Software of the DAQ 8.1 step by step -
the Automation explorer 4.03 only installed ok
the VI logger was causing the system not to boot
the NI-DAQ (without any other support selected) was causing the system not to boot

0 Kudos
Message 3 of 6
(3,008 Views)

Hi Andy,

 

The problem that you are experiencing is due to the BIOS of your particular PC.

 

I found an instance of the exact same behaviour that you have experienced by a customer with the same PC.

 

The notes from the application engineer who dealt with the issue previously show that he found a workaround: “To get the computer to boot, start up in safe mode and edited the registry tree "HKEY_LOCAL_MACHINE >> SYSTEM >> CurrentControlSet >> Services >> NIPALK" and change the "Start" key from "4" to "0". This allows the system to boot, but LabVIEW will not run.”

 

I have also found a Knowledge Base which refers to PCs with unsupported BIOS’ with the same behaviour as your PC. This contains a second workaround which should allow your PC to boot up:

http://digital.ni.com/public.nsf/websearch/1780FE4D49B70C0D86256FA2006B3369?OpenDocument

 

I hope that this helps you

 

Emma Rogulska

NIUK & Ireland

0 Kudos
Message 4 of 6
(2,975 Views)
Thanks for the hint.
Actually you are right, it is the nipalk.sys that is crashing the system.
I have gotten a new BIOS version 2.037 from tyan, but the problem is not solved after the BIOS update.

I wrote to tyan that :

"NI has told me that the problem can be caused by to following problem with
the BIOS:
This issue may be caused by your computer's BIOS. If it does not comply with
the PCI BIOS Specification (Revision 2.1 as published in 1994), you may
experience a system crash. In particular, calls into their BIOS32 Service
Directory to detect the PCI BIOS 32-Bit Service must return correct values
for both the base address and length of the service. Please check with your
computer vendor to determine if they have an updated system BIOS available.
Is this ok for the new BIOS version you gave me ?"

and I got the reply:

"we are already returning base address and length of the service. So there
must be another issue why NI doesn’t want our BIOS. We need detailed
information what is wrong."

So there is no solution to this problem up to now.


Any suggestions ?
0 Kudos
Message 5 of 6
(2,970 Views)
I have gotten the BIOS revision 2.03C from tyan for the thunder S2672. That solved the Problem with the NI-DAQ software
0 Kudos
Message 6 of 6
(2,946 Views)