Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Voltage qui décole brusquement avec des RTD

Bonjour,

Je voudrais acquérir les températures mesurées au moyen de 5 RTD. Je dispose d'une DAQcard-6036e à laquelle est relié un connecteur BNC-2110. Je ne dispose pas de matériel spécifique pour l'utilisation de RTD et je me suis donc débrouillé avec les moyens du bord : Les 5 sondes sont reliées en série avec une résistance de 27 kilo-ohms. J'alimente le circuit avec une tension stable de 27 V, ce qui me permet d'avoir un courant de 1 mA le plus stable possible. Les deux fils restants de chaque sonde sont branchés via 5 cables BNC sur les entrées AI0 à AI4 du BNC-2110. Les 5 entrées sont réglées en "ground-referenced source". Toutes les connections sont faites au moyen de sucres éléctriques (1 pour alimenter les sondes et 1 pour connecter les sondes aux cables BNC). J'ai créé dans MAX un canal virtuel pour chacune des 5 entrées. A chaque fois, j'ai spécifié "mode différentiel". Dans labview, je fais la moyenne des mesures faites sur chaque canal pendant une seconde, je transforme la tension mesurée en température et j'affiche les résultats sur un chart en fonction du temps.

En fait, ça fonctionne très bien...jusqu'à ce qu'inexpliquablement les 5 signaux décolent brusquement. Ca n'arrive jamais après la même durée d'acquisition. En seccouant quelque peu mes sucres, les signaux redeviennent corrects, ce qui me fait supposer un problème de contact à leur niveau. Ce que je trouve bizarre, c'est que quand le problème arrive, il suffit également de passer l'une des entrées utilisées sur le BNC-2110 en mode "floating source", puis de la remettre en "ground-referenced" pour que tout rentre dans l'ordre (temporairement...).

Quelqu'un a-t-il une idée? (autre qu'acheter un matériel spécialisé et couteux)

Je joins mon VI à tout hasard...
0 Kudos
Message 1 of 1
(2,290 Views)