Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Using GPIB, and connected to the device w/ drivers, why does the device not respond?

I am using GPIB to connect my Agilent Signal Generator to a VI.  I am using the correct port that the generator provides and correct VI's for this particular model (22330A).  Everything has run before but I am getting an error in MAX that says the GPIB has no connected interfaces?  How do I connect this signal generator?

Thanks

0 Kudos
Message 1 of 13
(4,363 Views)

Just need to clarify some things. By port, do you actually mean GPIB address? What do you mean 'has run before'? The error in MAX - is it saying no interfaces (i.e. no GPIB), or no instruments detected? I don't think that model number is correct. Also, what is the make and model of the GPIB controller? If it's an NI board, what version of NI-488.2 are you running?

 

p.s. You also posted to the mulit-function DAQ board and this should have been posted to the instrument control board.

Message Edited by Dennis Knutson on 09-05-2008 11:21 AM
0 Kudos
Message 2 of 13
(4,361 Views)
Sorry for the confusion and wrong posting area (can I change where this is posted now?).  The model for my 20 MHz Function/Waveform Generator is an Agilent 33220A.  It transmits using a GPIB address 10 (not port #).  I previously had labview running with GPIB  on a program I made and the GPIB worked fine.  The goal of my program is to use the signal generator to send an output at a specified voltage and frequency and to use my multi-funtion DAQ board (NI PCI-6251) to acquire the transfer function of two inputs.  The program works but I cannot get the GPIB to communicate with the generator anymore.  MAX recognizes the GPIB0 (GPIB-USB-HS) hardware but will not recognize any of the "other" non-NI hardware (we have several other types of electronics in the lab (signal generators, LCR meters, Universal Motion controllers, etc).  I am using NI-488.2 with a software version 2.52 and both the software and hardware (NI GPIB-USB-HS) pass when I use the troubleshooting utility.  Again, sorry for the incorrect terminology, I'm still novice with the electonics and labview.  Thanks for your help!
0 Kudos
Message 3 of 13
(4,349 Views)

Have you tried the instrument driver available for this instrument?

I have enclosed the link here.

 

Aglilent 33220A

National Instruments
Applications Engineer
0 Kudos
Message 4 of 13
(4,322 Views)

If you run MAX and select 'Scan for Instruments', you should be able to detect all of the GPIB instruments unless:

 

1. The controller has gone bad

2. One of the instrument's GPIB interface is defective and causing all to fail. Some faults can affect the entire bus.

3. A defective cable is being used. Again, some faults can affect the entire bus.

 

I would recomend that you disconnect everything and add one cable/one instrument at a time. If MAX still fails to return anything when you do a scan and there is only one instrument on the bus, you might want to try a different GPIB controller if you have one or try the one you have on another pc.

0 Kudos
Message 5 of 13
(4,320 Views)
If anyone is interested in this problem, I could not find an issue with any of the hardware (GPIB controller, cables, etc.) and changed the GBIP address and everything worked as normal.  Neither address was used on another instrument but this seemed to do the trick (I'm not sure why this would be the case but have not had any issues with the GPIB).
0 Kudos
Message 6 of 13
(4,254 Views)

I too have been unable to get the GPIB-USB-HS to work with VISA.  I am using CVI 8.5, MAX 4.3, VISA 4.2 and NI-488.2 2.5.  MAX does see the GPIB-USB-HS device, and instrument scans show all connected GPIB instruments.  My application code (either CVI or LabView) does NOT see any connected instruments.  viOpen calls generate the error "The interface type is valid, but the specified interface number is not configured."  Doing a resource scan using viFindRsrc returns only my asynchronous ASRL VISA devices (i.e.  my com and lpt ports).  This behavior is identical using LabView 8.5.   It appears that MAX is able to see the connected devices beacause it uses the low level GPIB commands and thus bypasses the VISA layer.  This is confirmed by NI-SPY.  The NI utility "VISA interactive control" also reports only the ASRL devices, and not the connected intruments.   All of the above (including executables) work as expected when using a similar usb-GPIB device from Keithley (KUSB-488).  A work-around for this seems to be that I must use only low level GPIB drivers, but that would require re-writting all of our existing VISA based code (and it also defeats the whole purpose of VISA).  

0 Kudos
Message 7 of 13
(4,077 Views)
My solution to this problem was simply to change the GPIB address.  I don't know why it worked but it did?  Good luck!
0 Kudos
Message 8 of 13
(4,067 Views)
Your mention of the Keithley device makes me suspect that somewhere and someplace you've got a wrong version of VISA installed. Are you going to be switching back and forth between Keithley and NI controllers? If not, uninstall everything related to VISA and start over with just NI-VISA.
0 Kudos
Message 9 of 13
(4,057 Views)

Thanks for you response Josh and Dennis.  I did try several other GPIB addresses without any luck.  Dennis you are right about the Keithley USB-GPIB drivers conflicting with the NI drivers -- they definitely cannot coexist.  But that wasn't my problem, each driver is smart enough to see the other and refuses to install itself until the other is removed first.  That pretty much precludes using both Keithley and NI USB-GPIB devices in one system, but that's ok.

After beating my head against the wall for a few more hours, I found that the problem was that that the NI GPIB-USB-HS device needs to have the NiVi488.dll passport explicitly enabled.  By default (inexpilcably), it is not -- ergo no VISA.   MAX is perfectly happy using just low level GPIB commands, so it thinks everthing is fine, but any applications using VISA commands do not work. Enabling the passport is simple enough, although it is well hidden in the MAX menus ( Tools -> NI-VISA -> VISA Options -> Passports).  After doing this, the NI device works just fine.

0 Kudos
Message 10 of 13
(4,018 Views)