Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Unable to load MIFSystemUtility DLL



I have installed NI Package Manager, and am trying to install NI DAQmx, but I keep getting the error "Unable to load MIFSystemUtility DLL". I am not sure how to fix this. I believe it may have arisen because the first time I tried installing it, my computer froze and I was forced to manually reboot it. How can I fix this DLL error so that I can install NI DAQmx?



0 Kudos
Message 1 of 18



I wanted to first inquire a little further into what actually happened when you had to manually reboot during the install of Package Manager. Are you sure that Package Manager installed correctly? Are you even able to open NI Package Manager? I just want to verify that you didn't corrupt the install of that software on your computer before trying to install other software. 


It seems very likely that the install may have been corrupted, so from this there are two options that I foresee solving your issue. 


1.) If you have an active service program with NI, then I would recommend opening a service request about this issue.

2.) Uninstall All NI Software from your computer. I know that this is a much higher effort than option 1, but this issue has the potential to occur with every new installation of NI software. NIPM will require that you uninstall all National Instruments Software before uninstalling Package Manager itself, so this may be the next best step to fixing your issue.






0 Kudos
Message 2 of 18

Hi Ryan,


I do believe the Package Manager installed correctly. I am able to open the package manager and search for the NI DAQmx software, and the installation procedure starts normally and works until I get the message "unable to load mifsystemutility DLL" after agreeing to the license agreements. Unfortunately I do not have a service program with NI, and I have tried completely uninstalling all NI software and then reinstalling the package manager, followed by the NI DAQmx. Doing this, the package manager installs correctly but I still receive the DLL error when trying to install the daq software. Are there any other options to resolve this issue?




0 Kudos
Message 3 of 18

I had this same error after attempting to clean all NI software and reinstalling fresh.  I had to edit the widows registry to find and remove most "MIFSystem", "National Instruments", "NationalInstruments" and "LabView" and " NXG" related items in order to have closer to a true clean install.  If this had not worked I would have refreshed to a new, clean windows install.  Sorry, I don't know the exact keys that did the trick, I tried a few times before it worked (There are so many NI registry entries...)  Also I looked though "remove programs" and found some VISA related entries that I uninstalled.  I was just finally able to install DAQmx.  I am really trying to fix a problem with application builder for LabView 19.  I think the trouble was having too many install/removes of older versions of various NI software including DAQmx, LabVIEW, and NXG.   Maybe NI can create a "clean" all NI software utility???

0 Kudos
Message 4 of 18

A "clean" all would be perfect and necessary!

However, up to now you can use a windows tool.


One just has to follow this fix guide and find all NI software which are making trouble.

0 Kudos
Message 5 of 18
I met the same problem now, did you fixed it finally? if you did, may you tell me how to solve it? thank you vey much. And i insatlled DAQ-mx 18.6 with offline package, it work well.
0 Kudos
Message 6 of 18



Even I've faced the same issue quite recently and the solution was provided by NI itself to eliminate the Windows Registry patching problem.


Please follow this link for detailed steps



Message 7 of 18

Thank you so much, it worked

0 Kudos
Message 8 of 18

This solution brought by NI works for me. 

0 Kudos
Message 9 of 18

What was that? 

0 Kudos
Message 10 of 18