Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

USB-6009 does not appear in MAX



I recently purchased a USB-6009 and it came with a NI-DAQmx 8.9.5 DVD. I would like to use this device with a Windows XP computer (Dell Latitude D400 laptop) and LabVIEW Run-Time Engine 7.0. I will develop a LabVIEW 7 Express application on a separate Windows XP computer.


I understand that NI-DAQmx 7.5 or higher is required for USB-600x devices and the NI-DAQ & LabVIEW compatibility chart shows that LabVIEW 7.0 is last supported by NI-DAQmx 8.1.


I have tried installing NI-DAQmx 7.5, 8.0.1, and 8.1. In all cases, the USB-6009 does not appear in MAX. A possible related symptom is that my DAQCard-6024E only appears in MAX under Traditional NI-DAQ Devices, when it is supposed to be supported by both NI-DAQmx and Traditional DAQ. Both the USB-6009 and DAQCard-6024E appear in the Windows XP Device Manager under Data Acquisition Devices.


The LED on the USB-6009 blinks; I understand that when the device is working properly it should be on continuously


Another symptom/problem is that when I run the NI Device Monitor (available with NI-DAQmx 8.0.1 and higher) I get the following error message:


nidevmon.exe - Entry Point Not Found

The procedure entry point ?isType@nNIMHWCF100@@YGKABU_GUID@@0AAVtStatus2@nNIMDBG100@@@Z could not be located in the dynamic link library nimhwcfu.dll.


Can anyone shed some light on this problem or offer any suggestions?


I will try the USB-6009 on another computer, but I would really like to get it working on the Dell D400.



0 Kudos
Message 1 of 5

Update... Installed NI-DAQmx 7.5 on a different computer (Dell Latitude D630) and both USB-6009 and DAQCard-6024E appear in MAX.


I still want to get this working on the Dell D400. I'm going to try uninstalling and re-installing all NI software and see if that helps.

0 Kudos
Message 2 of 5

Hi VictorY,


I think un installing and re installing should fix the issue. Sounds like you've got the version figured out, however down grading can be problematic, a complete un install should get you around that.


Let us know what you find.



Scott M.

Applications Engineer
National Instruments
0 Kudos
Message 3 of 5


I am having the exact same problem.  I uninstalled MAX and NI-DAQ 8.5 and then reinstalled them.  But Nnidevmon.exe still crashes with the same dll error.

Any ideas?

0 Kudos
Message 4 of 5



I ended up having my company's IT person re-format the hard drive on the Dell D400, and reinstall Windows XP and NI software. Not an ideal solution, but it works fine now. There must have been some software compatibility issue (not a hardware issue). As it was an old laptop and not being actively used, the clean installation was more cost effective than trying to track down software conflicts.



0 Kudos
Message 5 of 5