Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Trouble getting cDAQ-9137 up and running

Go to solution

Good morning,


I hope someone can help,  I have been given use of a compact DAQ device at work, and sent on training to learn to use labview. The device has been sitting un-used since purchase and I will be the first person to make use of it once I fathom how to get it up and running, It is a cDAQ-9137.


I have followed several guides and quick start documents I have found online, but all assume that at a certain point the device automatically will appear in MAX under remote devices. As you can see from my screenshot, mine does not. It also does not appear in Windows device manager.


I have included a screenshot showing the software list I have installed from the supplied USB stick.


The device I am told, is Linux, not windows, and so should appear.


Thanks a ton in advance, for any help you can give.

Download All
0 Kudos
Message 1 of 14

Can anyone help? I am completely stuck. Thank you

0 Kudos
Message 2 of 14

Where did you find the instructions ?? can you drop the link address or file?

Message 3 of 14



Notice at step number 6 it assumes the device to show up under remote systems.

0 Kudos
Message 4 of 14

Are you connecting your cDAQ-9137 to your PC with the USB cable supplied? If so, which USB port of cDAQ-9137 are you using?

You should connect the USB A-B cable to Number 15 shown on the page below.


Make sure your PC does not have any strong firewall set that blocks any unidentified USB device.


If you are using an ethernet cable, are both your PC and the cDAQ in the same subnet?


Looking at your screenshot, you might have forgot to install DAQmx Real-Time option. I suggest you try reinstalling DAQmx with custom install (not express) and choose deliberately to install the DAQmx RT option.

Message 5 of 14

Hi, and thank you very much for the reply!

I am connected using the port, and USB cable which you link to.

I have just ran through the installer again and made sure to select DAQ-MX Realtime to be installed. But the installer shows it as already present on my system ( I ran through the installer regardless just incase)


No change. The device must be recognised through USB as when I connect it to my machine it loads up NI Device Monitor, and appears in the devices and interfaces selection in MAX.

I have ordered a mini port display adapter, what am I likely to see when I connect a display to the device directly and will this help me?


Many thanks

0 Kudos
Message 6 of 14

I suggest then to right click on Remote Systems and use the troubleshooting utility to see if that detects any issues.

0 Kudos
Message 7 of 14

My cdaq is not listed on the list of devices?

When I click the link that says device not listed it says that no additional support files are available ( see screenshots I have included)

Download All
0 Kudos
Message 8 of 14
Accepted by topic author liquorice-allsorts

Please try what it says on page 1-14 to 1-15 on this manual.

Message 9 of 14

Wow, can't thank you enough, that instruction has solved the issue! Very well found.


Thanks again, have included a screenshot of the remote system now listed, just to bring this to a close.


0 Kudos
Message 10 of 14