Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Thermocouples on SCB-68 in RSE mode, 6024E DAQ card

Hello All,


   So after 3 days of being thwarted I've decided to give getting help a whirl again.


   The setup: I am reforming methane with plasma and have to keep track of the temperature of the gas flow.  I have thermocouples at various points.  I have a scb-68 board and a 6024E DAQ card.  I have labview 7.0.  The switches are set for temperature sensor enabled on single ended channel 0.  I have to run this in RSE mode.


   The Problem: All of a sudden my thermo couples are not reading the correct values anymore. On channel 0 the cjc temperature is still accurate at 27 degrees.  On any of the other channels eg. channels 1 and 8, the temperature (when the system is off they should read room temp) reads 50.1 or  so C instead of 26 or 27 C.


   Things I've looked at: 

Thermocouples, the SCB-68, and NI-DAQ Virtual Channels/NI-DAQmx Tasks

 From here I've been in MAX and looked at the traditonal virtual channels.  I have a virtual channel for the temperature with the built-in CJC (which is enabled via switches and working), when I test the devices through MAX they also read ~50C. 

and all other threads like it that suggest I run in differential mode.  I can not as I have too many devices, I need to run in RSE mode, it was working before.  I fear the software had a hicup or got toggled somehow/somewhere and is angry with me.  Or the computer is angry we have a new laptop, and has chosen to rebel.  Again I can not run in Diff mode.


How Do I Use the Cold Junction Compensation on the SCB-68?

At the bottom of this it says that "you cannot use a DAQmx temperature task. Instead, you will have to use an analog input task to read both AI 0 (the CJC) and your temperature channel, and then scale the raw voltage in software."

It then links you to


Manually Scaling Thermocouple Measurements in DAQmx

which has an example in labview 7.1.  I have labview 7.0 and this will not fly. 


   Why I need you:  Obviously I am missing something easy/obvious/critical here and thus my thermo couples are reading incorrectly and not being adjusted correctly with the CJC.  How do I "use an analog input task to read both AIO and the temperature channel (8) and then scale the raw voltage in software"?  Is there something else obvious I am doing wrong?



0 Kudos
Message 1 of 13

First off, I have attached the example from your last link saved back to LabVIEW 7.0.  It uses DAQmx functions, so you will need the driver installed.  I haven't looked at the corresponding NI-DAQ functions, but hopefully it will lead you in the right direction.



That said, I'm not sure how helpful that will be if you're not getting correct readings in MAX.  To check the rest of your setup, can you verify that you've checked the jumper settings on the SCB-68 for CJC in RSE mode?  Can you give us anymore information on what MIGHT have changed on the system since you said this was working before?  Did you re-create the virtual channels or anything like that?  What were you using to get correct readings before?


Let us know these specifics as well as the driver version you're using and hopefully we can narrow the problem down.

Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 2 of 13

Thanks for the example saved back to LabVIEW 7.0.  I looked at my software in MAX and it says that I have LabVIEW 7.0, Traditional NI-DAQ 7.0.0f8, and NI-DAQmx 8.0.0f0.  


I was able to run the program and it gave me the same temperature as everything else ~50C.


I am not the original developer of this software, so originally I sat down and hit start.  Since then we've added quite a few 4-20mA channels and everything continued to work fine. A fewdays ago I mistakenly tried to hook a 4 to 20mA channel upto pins 65 and 31 with the ground on 31 (the live channel for the thermo couple on channel 10, no TC is plugged in at the minute, wires are just plugged in going no where.)  Anyways there was no current on the channel (the pin on the flow meter hooked  into the system was not live at the time.)  I disconnected that and  moved the unit to channel 9 and it is working fine.  An hour or two later the thermocouples all started reading incorrectly.


I have checked the jumper settings on the SCB-68, they are correct for RSE mode.  Channel 0 is still  giving me a correct CJC temperature.


I've connected a screenshot of the labview program (simplified for just one of the thermo couples).  This is what use to work.  Now, not so much. If need be what would I need to attach to a reply for you to open my program?  All it is doing is looking at the CJC temp and one thermocouple.


When I looked in MAX there was nothing in the data neighborhood, i have since added virtual channels for the tranditional NI-DAQ as one of the articles in the knowledge base said the NI-DAQmx did not work well with the RSE.  These channels are also reading ~50C.


Thanks for the help! 

0 Kudos
Message 3 of 13

Even though your thermocouples are reading quite a bit off, do the values respond to temperature changes?


About the only other idea I have at the moment (if available) is to try different hardware.  Try changing out the DAQ card, SCB-68, and/or the cable.  Even though you said there was no current running when you wired the source incorrectly, something strange may have happened.


Let us know what you can do and we'll keep trying to help out!

Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 4 of 13

So I figured it out and it was stupid.  I have a cole-parmer mass flow meter that I had on the same power supply as the scb-68 board.  Somehow when the power supply for the mass flow meter was plugged in and it was also plugged into the scb-68 board's power supply the CJC's ambient temperature voltage would be added to the thermocouples temperature voltage.  When the power supply for the mass flow meter is removed and its only powered by the board everything works fine except it reads 3 degrees below what it should.  Removing the mass flow meter from the boards power supply fixed EVERYTHING.


However now the 6024E DAQ card is not being recognized by the laptop.  1 day of testing in... and the daq card stops working... Are there test programs for the DAQ cards?  The universe it thwarting my efforts! 

Thanks everyone for your help, the programs I was sent all worked... after the flow meter was removed.




0 Kudos
Message 5 of 13

Wow-good find on the power supply!  As for the computer recognizing the DAQ card, is it just not being recognized by NI software (MAX, LabVIEW, etc.) or is it not even showing up in Windows Device Manager?


If it's not showing up in Device Manager, re-seat the card and/or try it in another computer.  If it's just not being recognized as an NI card, you can try repairing the NI-DAQmx driver.

Alex Person
NI-RIO Product Support Engineer
National Instruments
Message 6 of 13

Egads, Thanks Alex, 

  Is it common for the drivers to commit suicide?  I updated the drivers to daqmx 9.0, now within the Measurement and Automation I can talk with my boards again!  So thanks for that bit.  I've got to be getting close to a functioning program once again. 
  My program is written in Labview 7.0 and now during the boot I get a truck load of missing .vi's.  Is there any place to download these?  Eg. "Configure DAQmx"

Thanks again!


0 Kudos
Message 7 of 13

So I realized that ni-daqmx while working with the hardware does not work with labview 7.0.  And now I'm having a crazy hard time downgrading.  I installed the full version.  


Uninstalling the daq-mx drivers did nothing.  How in the world do you downgrade?  As I'm sure someone will be dumb enough to do this again I started an aptly titled thread as there was not one already.


Thanks for the continued help. 

0 Kudos
Message 8 of 13

That is the correct way to downgrade.  Does 9.0 still show up in Add/Remove Programs or in Measurement and Automation Explorer?  I know this sounds simple but did you reboot the computer afterwards?


When you start the installer for the older version of DAQmx, what all shows up with red x's, everything?

Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 9 of 13

No, 9.0 does not show up in add/remove programs or in MAX.  And thanks for the check, I did restart the computer.  I've attached a screen capture of the programs still installed (MAX screenshot) and a screenshot of the 8.1 installer red x's.



Download All
0 Kudos
Message 10 of 13