Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Thermocouple Drift with NI 9205

Solved!
Go to solution

Hello,

 

I have an NI 9205 card in an NI cDAQ-9172 chassis as the only card connected, as our other single-card chassis are being used. I have 8 thermocouples in the card, in channels 0, 2, 4, 6, 16, 18, 20, and 22. They are showing a bit more noise than usual, but remain fairly steady at the correct temperature of 70°F for about 50 seconds, and then they all spike to roughly 2,000°F. If I grab and hold the wires, the temperatures will return to 70°F, but only for about 20 seconds before repeating the same behavior, requiring me to let go and grab them again.

 

Does anyone know what could cause this, or how to solve it?

 

Thank you,

Tristan

0 Kudos
Message 1 of 4
(2,615 Views)

Seems that you have floating inputs, measure differential and have no bias current path.

Connect a 1 Meg Ohm from each AIx- to GND and try again.

See manual. (RTFM 😉 )

 

How do you apply a CJC correction?

 

Noise: read with 1kSPS and capture 300ms (300sample) and calc the mean value. Usually most noise is line frequency ...  if faster reading is needed capture one periode of the line freq. or do more investigation: read a single channel as fast as you can and have a look how the noise looks like. 

A 470nF cap  accros the each channel can help sometimes. Dedicated TC capture units have noise filters included 😉

 

Greetings from Germany
Henrik

LV since v3.1

“ground” is a convenient fantasy

'˙˙˙˙uıɐƃɐ lɐıp puɐ °06 ǝuoɥd ɹnoʎ uɹnʇ ǝsɐǝld 'ʎɹɐuıƃɐɯı sı pǝlɐıp ǝʌɐɥ noʎ ɹǝqɯnu ǝɥʇ'


Message 2 of 4
(2,585 Views)

Hi Tristan

 

Additionally, please read the following white paper. 

http://www.ni.com/white-paper/3344/en/#toc6

 

It has a lot a good suggestions regarding noise and wiring for Analog inputs. 

 

Kind regards,

0 Kudos
Message 3 of 4
(2,571 Views)
Solution
Accepted by tyount19

I connected a negative lead from the negative port of the first channel to the COM port of the card and this cleared up my issue, thank you for setting me on the right path everyone!

Message 4 of 4
(2,560 Views)