Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Support of CDAQ-9181 in Linux?

Hello,

 

The latest version of NI-DAQmx for linux 19.1 appears not to support cDAQ-9181, according to the README file at URL  http://www.ni.com/download/ni-linux-device-drivers-2019/8283/en/

 

Are there any plans to provide a linux driver for this chassis?

 

Thanks.

0 Kudos
Message 1 of 4
(754 Views)

Hello there,

I'm sorry to say that there's no information regarding plans to release Linux driver for the chassis. The workaround, that you might've already tried is to use a Virtual Machine instead.

 

Thank you.

0 Kudos
Message 2 of 4
(679 Views)

It is unfortunate that NI chose to treat Linux as a second-class citizen, considering its clear lead over windows in embedded applications. When making a selection, I did not expect that an ethernet-based device would be so poorly supported.  The experience will without question influence my future decisions and recommendations to colleagues.

0 Kudos
Message 3 of 4
(671 Views)

The cDAQ-9185 and cDAQ-9189 Ethernet chassis are supported in NI-DAQmx 19.1 for Linux.

 

The cDAQ-9181 is part of an older generation of chassis and is not currently supported.

——
Brandon Streiff
ni.com/compactdaq · ni.com/daq
0 Kudos
Message 4 of 4
(657 Views)