Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Set 6009 to push/pull on Mac OSX



I've tried following the instructions on this page:


And haven't had any luck. Is there something I need to do to enable the task?

0 Kudos
Message 1 of 7

What version of DAQmx Base do you have installed? What version of LV and what version of OS X?


What happens when you run the Configuration Utility? 


I do not have any NI hardware at the moment so I cannot test things.



0 Kudos
Message 2 of 7

DAQmx Base 3.7, OS X 10.9. I don't know what LV is. This is my first time configuring NI hardware. When I run the configuration utility it seems to load normally, and it sees my DAQ.

0 Kudos
Message 3 of 7

LV is an abbreviation for LabVIEW, NI's graphical programming language.


DAQmx base only supports 32-bit applications, even on 64-bit OSes. The note is on the fifth page of the DAQmx Base Read Me in the System Requirements paragraph.  Could that be your problem? 



0 Kudos
Message 4 of 7

Thanks for the response. Maybe it will help if I explain what I'm expecting to see:


I follow the following instructions from this page:


Select Create New Task

  1. Choose Digital I/O as the acquisition task type and give the task a name
  2. After the task is created, select the Voltage Tab.
  3. In the Voltage Tab, there is a DIO Voltage Level option. For open-drain, use the 0-5V option. For push-pull, use the 0-3.3V option.

And the DAQ output lines should now output 0-3.3V. However, when I follow these instructions exactly, the output remains at 5V (the default output is HIGH on the 6009). Is there something else I have to do to "enable" this "task?" The quotes aren't meant to convey any attitude, I'm just unfamiliar with the vocabulary.


I'm not using LabVIEW, and I'm not sure about the 32bit issue. The software I'm using to control the DAQ seems to be working fine (i.e. I've tested that it can set the DIO lines). It's surprising to me that you bring this up, because it seems to me that the only "application" (again, a loaded term - I'm not sure what is meant by "application" in this context) in play here should be DAQmx Base itself.

0 Kudos
Message 5 of 7

It is not completely clear from the documentation on the USB-6009 but it appears that the 4700 ohm pull up resistor to +5 V may be present even when the device is programmed for active output. If the driver circuit does not clamp the output at 3.3 V, the pull up resistor may take the voltage to 5 V with no load.


Try connecting a 4700 ohm resistor from the output to ground. If the device is in open collector mode or input mode, the voltage should be near 2.5 V. In active drive mode the voltage should be about 3 to 3.3 V or 3.5 to 5 V depending on the voltage setting.


I am not sure of the significance, if any, of the 32-bit issue. I was just mentioning something I saw in the Read Me file. It does make a difference with LabVIEW. However since your code seems to be working, it is apparently not an issue.



0 Kudos
Message 6 of 7

Good idea. I checked this, and the voltage is at 2.5, so clearly still in open collector mode.

0 Kudos
Message 7 of 7