Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Reading SSI absolute encoder with USB-6008 DAQ

Highlighted

Hello John:

Actually, I ever try to get the data based on your original vi. that you compile, but it shows the problems as I sent to you in attachment. In order to solve this problem, I try to fix it and change the value. But it doesn't work neither. I don't know what happened. I will try once more following your advice and see what will happen.

Thanks a lot!

Best regards,

Boborain

 

0 Kudos
Message 41 of 49
(1,376 Views)
Highlighted

Hello John:

Last time, you show me many advice about the digital encoder advices, but I can't fix the problems and tried many ways. Now I have to change to the new encoder.

But, it seems the new encoder doesn't work well. Please see the attachment. This encoder is analog one, should be much simple than the digital one. Unlucky, I don't get things down.

Would you please help me to check what's the problem?

Thanks a lot!

Best regards,

Boborain

Download All
0 Kudos
Message 42 of 49
(1,348 Views)
Highlighted

HI boborain,

 

The AO current drive is only 5 mA.

 

Every time you post it's a completely new and unrelated question--this is my last post on this thread.  If you need additional assistance you should start a new thread, but before you post please make sure to look into the issue a bit yourself first.

 

 

Best Regards,

John Passiak
0 Kudos
Message 43 of 49
(1,345 Views)
Highlighted

Hello John:

I start a new thread about the questions as I mentioned last time. I do try different ways to solve the problems. You said I input the 5mv, I used the analog input to check output ao3, it does show 2.5 V. You can see from my attachment.  And also, I use the DC power supply 5 V, the output shows the square wave, that's not I want to get. Thanks a lot for your reply.

Best regards,

Boborain

  

0 Kudos
Message 44 of 49
(1,336 Views)
Highlighted

You are confusing Volts and Amps.

John Passiak
0 Kudos
Message 45 of 49
(1,330 Views)
Highlighted

Hello John:

This time I try to use the analog output ao3 to supply the encoder power, it works. But I changed nothing, just following the progress I show you last time.

Anyway, I get the result. How is your viewpoint?

Thanks a lot!

Best regards,

Boborain

0 Kudos
Message 46 of 49
(1,310 Views)
Highlighted

Hello guys,

 

I need help...
I'm using a 13bits magnetic encoder with a SSI1 interface output. Which means that I've got 4 wires : DATA+ / DATA- / CLK+ / CLK-

I have no idea how to connect these wires to my USB6353 X series and if you can help me for reading my datas in Labview it would be fantastic.
I am a beginner in Labview.

 

Cheers.

0 Kudos
Message 47 of 49
(1,159 Views)
Highlighted

Hello,

I just want to know if I can use the soft posted on page 2 with my SSI encoder.

4 wires : DATA+ ; DATA- ; CLOCK+ ; CLOCK -

 

Thanks.

 

0 Kudos
Message 48 of 49
(1,053 Views)
Highlighted

Hello John,

 

I am actually trying to acquire encoder signal with SSI, so I am interesting in your AbsoluteEncoderCounters.vi

 

So, correct me if I am wrong but I understand that:

- the Dev1/ctr0 delivers the CS

- the Dev1/ctr1 delivers the CLK

- the Dev1/port0/line2 receives the DO

 

But, I am wondering what is the purpose of the Dev1/ctr2, it seems to be a clock with a period of 2e-7s and with a delay 1e-7. But I don't see the purpose of this clock with respect to the chronogram ?

 

Thank you

 

0 Kudos
Message 49 of 49
(321 Views)