Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with connecting 9191 chassis to a wireless network

Solved!
Go to solution

Hi

I don't seem to be able to connect a 9191 unit to our wireless network with WPA authentication mode. I'm trying to connect to an acess point based on SonicWALL TZ 105 Wireless router. Our wireless network is setup with WPA2-PSK security. When I go to network configuration page of 9191 our network shows up but then I receive "Invalid WEP Key" error when I enter the security key and try to save the configuration (see attached image). I tried using both MAX and web based configuration. I also established that wireless connection can be made if I change the security mode on the router to WEP, but neighther WPA-PSK nor WPA2-PSK work. I have not tried Enterprise type security modes becasue they are not setup on our network. I tried to play with WPA security settings but did not have much luck either.

 

Any advise will be very appriciated!

 

Regards,

Misha

0 Kudos
Message 1 of 6
(3,651 Views)

Hi Misha-

 

The screenshot you sent seems to show that the cDAQ-9191 "thinks" it is trying to connect to a WEP network.  This could be a problem with the cDAQ-9191 or something out of sync between the cDAQ-9191 and the access point.

 

Do you have access to an AirPcap or other device that is capable of capturing wireless beacons from the router so that we could inspect the contents and debug further?  Do devices other than the cDAQ-9191 correctly recognize this network as a WPA-PSK setup?

 

I found a document from SonicWALL that makes it clear that WPA mode is supported only in AP (access point) mode and not in bridge mode.  Can you confirm that your router is NOT configured for bridge mode?

Tom W
National Instruments
0 Kudos
Message 2 of 6
(3,641 Views)

I forgot to mention- if you choose the option to manually enter network settings, you may be able to overcome this autoconfiguration issue.

 

Hopefully this helps-

Tom W
National Instruments
0 Kudos
Message 3 of 6
(3,639 Views)

Tom, thank you very much for prompt reply!

 

Unfortunately I don't have any special tools to monitor wireless traffic.

 

Yes, other devices (laptops, phones) recognise the network as WPA-PSK and work fine.

I also confirm that the router is configured as an access point and not as a brigde.

 

I didn't quite follow your last remark regarding manual versus auto configuration. Where do I look for this option? I could not find anything like that in 9191 configuration.

 

Regards,

Misha

0 Kudos
Message 4 of 6
(3,630 Views)
Solution
Accepted by topic author mihonyc

Hi Misha-

 

Apologies for not being clear- I was speaking from memory on the manual entry option.  

 

Under Wireless Network, choose 'Other Network.'  This will allow you to manually entry the security type, SSID (network name), and WPA-PSK passphrase.

Tom W
National Instruments
0 Kudos
Message 5 of 6
(3,628 Views)

Tom

Thank you very much for the advise - going through "Other network" option did the trick

 

With best regards,

Misha

0 Kudos
Message 6 of 6
(3,621 Views)