Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Problem with thermocouple measurement suddenly going bad

I'm making long term temperature measurements using a PCI6040E, SCXI1001, SCXI1102 32-channel thermocouple amp and a SCXI1303 isothermal block. These are making readings using J type t'couples. My customer's problem is that the measurements will be fine for a period of time (minutes, several hours) and then suddenly some channels will start giving really bogus temperatures, i.e.: -270 DegC vs the more realistic 35 DegC. I came in the last time it was doing this and when I went down into the code to my DAQ portion the DAQmx Read vi, set as analog, temperature, J type measurement was returning those numbers for the offending channels. Some were still giving valid numbers while others were giving the weird numbers and when a Fluke meter was used to measure the output of the "bad T'couple" it too was giving valid numbers. When I stop the LabVIEW program and go into DAQmx to try and troubleshoot it, there usually seems to be no problem. If I restart the LabVIEW program there also seems to be no problem, but when there is those numbers are coming out of the lowest level of code that I have programmed (the standard DAQmx read). I'm suspecting something "electromechanical" like connectors in/on the SCXI chassis, but the fact that it goes away when software is restarted is confusing me, as well as making troubleshooting difficult.


Thanks,

Putnam Monroe
Putnam
Certified LabVIEW Developer

Senior Test Engineer North Shore Technology, Inc.
Currently using LV 2012-LabVIEW 2018, RT8.5


LabVIEW Champion



0 Kudos
Message 1 of 2
(1,136 Views)
Hello Putnam:

First off, I would like to know if this application has every worked in its entirety. If it has, has anything changed at all? If so, this could help determine what is going wrong.

I have a couple of other ideas:
1. Have you tried replacing the thermocouple? A bad thermocouple could produce unexpected behaviors as outlined in your message.
2. What version of NI-DAQ drivers do you have? I would strongly advise upgrading to the latest drivers (7.3) You can download our drivers by going to www.ni.com/support/ and then choosing "Drivers and Updates" under option 3.
3. Do you have another SCXI 1102 module that you can swap for your current one? There is a small possibility that your module has gone bad.
4. Have you tried running your application on a different computer?
5. How many channels are you using on the SCXI 1102? Have you tried just using 1 channel and seeing what happens? What I want to know is, does this behavior occur on this channel when it is part of a group or even when it is the only one in use?

Lastly, do you have any other modules in your system besides the SCXI 1102? What happens if you remove them and just run your thermocouple module alone?

I would advise trying a few of these options so we can get a better idea on where the problem actually lies.

Thanks

Jaideep J
Applications Engineer
National Instruments
0 Kudos
Message 2 of 2
(1,117 Views)