Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Problem loading NI9239: Error -50251

Go to solution


    I am using NIcDAQ9172. And NI 9239 data acquisition card in one of the slots. I am having trouble with this card as I am trying to use it in signal express. After trying to run it it game me an error saying 'The is not available'. I tried connecting using Labvoew vi and it does not show up in available device. So, finally I launched MAX and tried inspecting the board. When I ran the self test, the result says 'The driver successfully communicated with cDAQ1Mod2'. Now, when I click test panels, and start the acquisition for any  channel, it gives me an error saying       'Error -50251 occurred at DAQmx Start   Possible Reason(s): NI Platform Services: specified software component is not available. The component was not loaded.'    

    The whole setup did work until yesterday, and stopped working since this morning. There was no change in hardware or software. I also tried using different computers and I got the same errors.

Does anyone have any idea why is it happening or what is going wrong? any inputs are greatly appreciated.





Kudos are (always) welcome for the good post. 🙂
0 Kudos
Message 1 of 2
Accepted by topic author odessy27

All Right, so after one day full of tril and error, it turns out that the new daqmx drivers that I had installed (DAQmx v9.5) was causing troubles, it was letting MAX to detect the hardware but not run it. So I uninstalled the drivers and rolled it back to v9.1.1 and now everything works just fine. Conclusion: Be very careful while installing latest drivers with older version of LabVIEW (in my case LV2009). 

What puzzled me more was, after installing those latest drivers everything worked fine for one whole day. and next day I stated having problem. Nothing was changed overnight and computers were not shut down or anything like that. So if it was a driver issue (and as it turnes out it IS), how did everything worked fine for one whole day? Also, for DAQmx driver download page there is no mention of their compatibility with versions of LabVIEW. 



Kudos are (always) welcome for the good post. 🙂
Message 2 of 2