Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Phantom PCI-4472

Solved!
Go to solution
Highlighted

Turned on a tester this morning and found out we have some brand new cards installed...allegedly.  The pair of PCI-4472 are not physically present, we do not have any of this model in the company.  Never added them as simulated devices or tried to Create New.  MAX 4.7 and DAQmx 9.1.5.  More than an annoyance, these cards took the Dev1 and Dev2 slots which pushed my real cards down the list and broke my program.  Renamed everything back to normal, set the 4472s as Dev8 and 9 to hopefully keep them out of the way.  Rebooted and now one 4472 is green like it's actually recognized by the PC.  Tried a self test and MAX threw an error, saying it wasn't found.  Serial #, bus location, etc are all 0.

 

This happened on another computer a few months ago but it didn't affect anything so I didn't do much about it.  Any ideas?nidaq.PNG


--Using LV8.2, 8.6, 2009, 2012--
0 Kudos
Message 1 of 3
(1,448 Views)
Highlighted
Solution
Accepted by topic author taper

taper,

 

There was a bug in multiple DAQmx versions where USB HID class devices would be mis-detected as NI Devices.  See this knowledge base. The knowledge base contains patches for affected versions of DAQmx.

 

Hope that helps,
Dan

0 Kudos
Message 2 of 3
(1,445 Views)
Highlighted

Guess that bug fix didn't show up in my search because I was having additional cards, not missing USB DAQs.


--Using LV8.2, 8.6, 2009, 2012--
0 Kudos
Message 3 of 3
(1,427 Views)