Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

No DAQ Assistant in Input

My laptop is Windows XP, my desktop is Windows 7, I've done different versions of DAQMX, etc.

 

I just can't figure out what this is, unless it's a specific problem with my LabView 2011.

0 Kudos
Message 11 of 21
(2,963 Views)

Hi BrianDavis,

 

Just to verify, the versions of the DAQmx drivers that are compatible with LabVIEW 2011 are DAQmx 9.3.5 and DAQmx 9.4, which can be seen on the NI-DAQ and LabVIEW Version Compatibility KB.

 

Can you verify that you are using one of these versions of the DAQmx driver?

You can open Measurement & Automation Explorer, expand software and look at the version of NI-DAQmx Device Driver to check.

 


Milan
Message 12 of 21
(2,930 Views)

I too am unable to see DAQ Assistant in LabView. I am running LabView 8.2 on Windows XP, with a NI PCI-MIO-16XE-50 card.

 

I had first installed DAQmx 9.4, but after learning about version incompatibilities I uninstalled all DAQmx 9.4 components using MSIBLAST.exe, and then installed DAQmx 9.1.1 and the associated patch.

 

I can view my device in MAX, but DAQ Assistant is not appearing under Functions>Express>Input in LabView.

 

I tried to follow Allie F's advice upthread, using Add/Remove Programs to modify NI DAQmx 9.1.1. Under "Application Development Support" I can see that "LabView 8.2 Support" has a green check, but the text in the right panel says "This feature will not be installed. A higher version of this product is already installed on your computer."

 

I tried to "Repair" NI DAQmx 9.1.1 (and the patch) but did not see a difference.

 

I have also looked in the folder "C:\Program Files\National Instruments\LabVIEW 8.2\vi.lib\express" but there are no DAQ Assistant related VIs.

 

Does anyone have any suggestions on how to get DAQ Assistant and other DAQ-related VIs properly installed on my system? Thanks.

0 Kudos
Message 13 of 21
(2,915 Views)

Thanks, especially for that link.

 

It was more than once that I downloaded the "top link on the page" and somehow wound up with 9.3.0.  I would even try an upgrade and it would say that I had a more recent version when I was reinstalling 9.3.0.

 

9.4.0 is installed and DAQ Assistant is working on my desktop, and now my laptop is in work and looks promising.

 

Thanks again.

 

Brian

0 Kudos
Message 14 of 21
(2,904 Views)

@BrianDavis

I am glad getting the DAQmx drivers that are compatible with your installation worked for you Smiley Happy

 

@MaryamAli

It looks like DAQmx 9.1.1 is the newest drivers compatible with 8.2 so if it installed correctly the files should be there. The KB entitled "Missing Icons on Functions or Controls Palette in LabVIEW" should give you information on checking if the DAQmx menus have been installed and the file location for them.

I do not have LabVIEW 8.2 installed, but for 8.6 the menu files for DAQmx are located at \labview\menus\Categories\Measurement\daqmx.mnu, so I imagine the location is similar for LabVIEW 8.2.

The KB describes how to add these menu files to LabVIEW.

 

In general the installer should do this automatically. So you can also try uninstalling all current DAQmx drivers and reinstalling the 9.1.1 DAQmx drivers again.

 


Milan
0 Kudos
Message 15 of 21
(2,885 Views)

@MilanR

 

Thank you for your response. Unfortunately my problem goes beyond the menus. It appears that the DAQ-related libraries (e.g. in DAQmx, _DAQmxBase folder) are not installing on my computer. I have repeatedly uninstalled and reinstalled NI-DAQmx 9.1.1 +patch, but the DAQ libraries don't show up.

 

I noticed that when I install DAQmx, the installer says about "NI-DAQmx 9.1.1 > Application Development Support > LabVIEW 8.2 Support" that "This feature will not be installed. A higher version of this product already is installed on your computer" (see attached screenshot).

 

I assume I need to uninstall the higher versions of "LabVIEW 8.2 Support" before installing NI-DAQ 9.1.1, but there is no item by this name under Add/Remove Programs > National Instruments Software.

 

How can I uninstall this higher-version LabView Support so that DAQmx 9.1.1 will install properly?

 

Thanks.

0 Kudos
Message 16 of 21
(2,867 Views)

I'm also new in LabView and I have installed a USB-6501.  I'm trying to create a VI according to the tutorial instructions but when I put in the diagramme  DAQ Assistant, the window to configurate this module is not opened. What coould be the cause?

 

0 Kudos
Message 17 of 21
(1,808 Views)

Martin,

 

 We have a pretty active community here at NI. I can see that the post you commented on hasn't been active for a while. I would advise you make a new post with the same information so more people will be able to see it and add insight on your issue or gain knowledge from it.

 

Regards,

 

Ali S.
Applications Engineering
National Instruments

 

 

Regards,

Ali S.
Applications Engineering
National Instruments
0 Kudos
Message 18 of 21
(1,792 Views)

Check to insure that you've installed the full version of the NI-DAQmx software, not just the runtime version.

 

Both are huge downloads, 1.9GB for full version, 1.2GB for runtime version.  The runtime version does not contain the necessary LabView files.

 

I found the download link via the 'Description' dropdown section "NI-DAQmx Runtime 17.0.0 with Configuration Support provides a smaller footprint runtime driver for deploying applications developed using NI-DAQmx 17.0.0 (Full Version)."

 

Hope this helps save you some time.

 

M.Popp

0 Kudos
Message 19 of 21
(1,104 Views)

I HAVE THE SAME PROBLEMS TOO.NO DAQ  ASSISTANT IN MY SYSTEM 

0 Kudos
Message 20 of 21
(965 Views)